aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-03-21 02:03:46 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-03-21 02:03:46 +0400
commit43cc8ffab5027662c7bdf1d80ccce4a2c73d0f87 (patch)
treef08d632c7996e439516a8d69f6de04a2ee5dffb2
parentsys-libs/gcompat: Add missing metadata entry for USE=libucontext (diff)
downloadguru-43cc8ffab5027662c7bdf1d80ccce4a2c73d0f87.tar.gz
guru-43cc8ffab5027662c7bdf1d80ccce4a2c73d0f87.tar.bz2
guru-43cc8ffab5027662c7bdf1d80ccce4a2c73d0f87.zip
games-strategy/armies-of-exigo-demo: new package
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
-rw-r--r--games-strategy/armies-of-exigo-demo/Manifest1
-rw-r--r--games-strategy/armies-of-exigo-demo/armies-of-exigo-demo-1.0.ebuild56
-rw-r--r--games-strategy/armies-of-exigo-demo/metadata.xml12
3 files changed, 69 insertions, 0 deletions
diff --git a/games-strategy/armies-of-exigo-demo/Manifest b/games-strategy/armies-of-exigo-demo/Manifest
new file mode 100644
index 0000000000..97ac98e107
--- /dev/null
+++ b/games-strategy/armies-of-exigo-demo/Manifest
@@ -0,0 +1 @@
+DIST armies-of-exigo--single-player-demo--portable-without-installer.tar.xz 97293504 BLAKE2B c9441d12795273cae4118ddab3e2fdd5df6c621b351f4370f8aba18310cec80a0d02295f343e4639236ca034a055491a9b714ddf2c2e8cd54c492eceb787b4f9 SHA512 b6121c64503fa7362a4c3050f601fa0c365b3154783c7e1fc84307e933f76b8b3fa9fe5061af6fa3fa813e88e680ef1b9ad8e34b4bf2f5d45a884e20f580b078
diff --git a/games-strategy/armies-of-exigo-demo/armies-of-exigo-demo-1.0.ebuild b/games-strategy/armies-of-exigo-demo/armies-of-exigo-demo-1.0.ebuild
new file mode 100644
index 0000000000..c8c0125fd8
--- /dev/null
+++ b/games-strategy/armies-of-exigo-demo/armies-of-exigo-demo-1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit wrapper
+
+DESCRIPTION="Single and multiplayer demo of Armies of Exigo (like WarCraft III), Windows"
+HOMEPAGE="https://en.wikipedia.org/wiki/Armies_of_Exigo"
+
+SRC_URI="https://archive.org/download/armies-of-exigo--single-player-demo--portable-without-installer.tar/armies-of-exigo--single-player-demo--portable-without-installer.tar.xz"
+# TODO add multiplayer demo
+
+KEYWORDS="~amd64"
+S="${WORKDIR}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+RESTRICT="strip"
+
+RDEPEND="
+ ~games-emulation/conty-1.25.2:0
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+
+ conty=conty-1.25.2
+
+ single=armies-of-exigo-demo-single
+
+ mkdir -p "$ED"/opt/armies-of-exigo
+
+ name=armies-of-exigo--single-player-demo--portable-without-installer
+
+ cp -r "$name" "$ED"/opt/armies-of-exigo/single-player-demo
+
+ path="/opt/armies-of-exigo/single-playerdemo/Exigo_spdemo.exe"
+ make_wrapper "$single" "$conty wine \"$path\""
+ # TODO add USE flag to be able to choolse local wine or wine-proton, against 1.4 GB dependency?
+
+}
+
+pkg_postinst() {
+ einfo "More about the game:"
+ einfo "https://en.wikipedia.org/wiki/Armies_of_Exigo"
+ einfo "Discord: https://discord.gg/HcsjkNX3JY"
+ einfo "https://armies-of-exigo.fandom.com/wiki/Armies_of_Exigo_Wiki"
+
+ einfo "This great game from 2004 is an abandonware - in 2024 you can buy it only as a second-hand CD."
+ einfo "List of creators: https://www.mobygames.com/game/16100/armies-of-exigo/credits/windows/"
+ einfo "If you want - please try to communicate with authors about making Armies of Exigo free and open source,"
+ einfo "or Intellectual Property holder can make a remake - add more display resolutions, improve the AI,"
+ einfo "make in runnable on modern Windows"
+}
diff --git a/games-strategy/armies-of-exigo-demo/metadata.xml b/games-strategy/armies-of-exigo-demo/metadata.xml
new file mode 100644
index 0000000000..59b728cfaa
--- /dev/null
+++ b/games-strategy/armies-of-exigo-demo/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Vitaly Zdanevich</name>
+ <email>zdanevich.vitaly@ya.ru</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">robert7/nixnote2</remote-id>
+ <bugs-to>https://github.com/robert7/nixnote2/issues</bugs-to>
+ </upstream>
+</pkgmetadata>