aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-10-22 15:50:28 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-10-22 15:50:28 +0200
commit692c9c79a58ebf689314a5174f46615597c9d121 (patch)
tree9c2c3c4c37c94f72cd7e0bfe909878c9204290b1
parentgames-action/minecraft-launcher: beta to stable (diff)
downloadguru-692c9c79a58ebf689314a5174f46615597c9d121.tar.gz
guru-692c9c79a58ebf689314a5174f46615597c9d121.tar.bz2
guru-692c9c79a58ebf689314a5174f46615597c9d121.zip
media-video/syncplay: beta to stable
split up patch file cause that makes repoman happy Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--media-video/syncplay/Manifest2
-rw-r--r--media-video/syncplay/files/syncplay-make-qpixmap-to-qicon-conversion-explicit.patch163
-rw-r--r--media-video/syncplay/files/syncplay-make-qpixmap-to-qicon-conversion-explicit2.patch176
-rw-r--r--media-video/syncplay/syncplay-1.6.6.ebuild (renamed from media-video/syncplay/syncplay-1.6.6_beta2.ebuild)7
4 files changed, 179 insertions, 169 deletions
diff --git a/media-video/syncplay/Manifest b/media-video/syncplay/Manifest
index bfc202ab0..673b479ff 100644
--- a/media-video/syncplay/Manifest
+++ b/media-video/syncplay/Manifest
@@ -1 +1 @@
-DIST syncplay-1.6.6_beta2.tar.gz 1843024 BLAKE2B d5c1e9e4c7b220722fef263f96749af22965bd26b82d41b913660d8b5c70bb6fe82727d7b16492408db661cf77eed4602c201cf90b05b3ee01a51dbfb7f3ee10 SHA512 c9ec87632418dd18b62fe392458a56a23c6eb2bae33c5a6be6daa94bfc30153fb371b9fa524452bdf2329442eb073f8f77418da823eac49273e8611d404d2f8e
+DIST syncplay-1.6.6.tar.gz 1842916 BLAKE2B 99db5862879046d6bc516590b2b7afb5092db887a86ab6f4d253b5eb34ae909020e2678e950719af8bb5665201b36cae9643ab796b942959fcd2b04bf995ad6d SHA512 bb91829434002b87834c373908f43629ef74e4db31b3ed06c5cb30bf7ca43326bc40fbe627dca89d7b7d45db72ca80f57de114c5613b9e3f63db4bcd4827430f
diff --git a/media-video/syncplay/files/syncplay-make-qpixmap-to-qicon-conversion-explicit.patch b/media-video/syncplay/files/syncplay-make-qpixmap-to-qicon-conversion-explicit.patch
index 2ff08f7e2..8caef4955 100644
--- a/media-video/syncplay/files/syncplay-make-qpixmap-to-qicon-conversion-explicit.patch
+++ b/media-video/syncplay/files/syncplay-make-qpixmap-to-qicon-conversion-explicit.patch
@@ -157,166 +157,3 @@ index c59c5697..2a4bd1a5 100755
getMessage("joinroom-label"))
window.roomButton.pressed.connect(self.joinRoom)
window.roomButton.setFixedWidth(window.roomButton.sizeHint().width()+3)
-@@ -1620,24 +1620,24 @@ def addPlaybackLayout(self, window):
- window.playbackFrame.setLayout(window.playbackLayout)
- window.seekInput = QtWidgets.QLineEdit()
- window.seekInput.returnPressed.connect(self.seekFromButton)
-- window.seekButton = QtWidgets.QPushButton(QtGui.QPixmap(resourcespath + 'clock_go.png'), "")
-+ window.seekButton = QtWidgets.QPushButton(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'clock_go.png')), "")
- window.seekButton.setToolTip(getMessage("seektime-menu-label"))
- window.seekButton.pressed.connect(self.seekFromButton)
- window.seekInput.setText("0:00")
- window.seekInput.setFixedWidth(60)
- window.playbackLayout.addWidget(window.seekInput)
- window.playbackLayout.addWidget(window.seekButton)
-- window.unseekButton = QtWidgets.QPushButton(QtGui.QPixmap(resourcespath + 'arrow_undo.png'), "")
-+ window.unseekButton = QtWidgets.QPushButton(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'arrow_undo.png')), "")
- window.unseekButton.setToolTip(getMessage("undoseek-menu-label"))
- window.unseekButton.pressed.connect(self.undoSeek)
-
- window.miscLayout = QtWidgets.QHBoxLayout()
- window.playbackLayout.addWidget(window.unseekButton)
-- window.playButton = QtWidgets.QPushButton(QtGui.QPixmap(resourcespath + 'control_play_blue.png'), "")
-+ window.playButton = QtWidgets.QPushButton(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'control_play_blue.png')), "")
- window.playButton.setToolTip(getMessage("play-menu-label"))
- window.playButton.pressed.connect(self.play)
- window.playbackLayout.addWidget(window.playButton)
-- window.pauseButton = QtWidgets.QPushButton(QtGui.QPixmap(resourcespath + 'control_pause_blue.png'), "")
-+ window.pauseButton = QtWidgets.QPushButton(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'control_pause_blue.png')), "")
- window.pauseButton.setToolTip(getMessage("pause-menu-label"))
- window.pauseButton.pressed.connect(self.pause)
- window.playbackLayout.addWidget(window.pauseButton)
-@@ -1657,13 +1657,13 @@ def populateMenubar(self, window):
- # File menu
-
- window.fileMenu = QtWidgets.QMenu(getMessage("file-menu-label"), self)
-- window.openAction = window.fileMenu.addAction(QtGui.QPixmap(resourcespath + 'folder_explore.png'),
-+ window.openAction = window.fileMenu.addAction(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'folder_explore.png')),
- getMessage("openmedia-menu-label"))
- window.openAction.triggered.connect(self.browseMediapath)
-- window.openAction = window.fileMenu.addAction(QtGui.QPixmap(resourcespath + 'world_explore.png'),
-+ window.openAction = window.fileMenu.addAction(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'world_explore.png')),
- getMessage("openstreamurl-menu-label"))
- window.openAction.triggered.connect(self.promptForStreamURL)
-- window.openAction = window.fileMenu.addAction(QtGui.QPixmap(resourcespath + 'film_folder_edit.png'),
-+ window.openAction = window.fileMenu.addAction(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'film_folder_edit.png')),
- getMessage("setmediadirectories-menu-label"))
- window.openAction.triggered.connect(self.openSetMediaDirectoriesDialog)
-
-@@ -1671,7 +1671,7 @@ def populateMenubar(self, window):
- if isMacOS():
- window.exitAction.setMenuRole(QtWidgets.QAction.QuitRole)
- else:
-- window.exitAction.setIcon(QtGui.QPixmap(resourcespath + 'cross.png'))
-+ window.exitAction.setIcon(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'cross.png')))
- window.exitAction.triggered.connect(self.exitSyncplay)
-
- if(window.editMenu is not None):
-@@ -1683,19 +1683,19 @@ def populateMenubar(self, window):
-
- window.playbackMenu = QtWidgets.QMenu(getMessage("playback-menu-label"), self)
- window.playAction = window.playbackMenu.addAction(
-- QtGui.QPixmap(resourcespath + 'control_play_blue.png'),
-+ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'control_play_blue.png')),
- getMessage("play-menu-label"))
- window.playAction.triggered.connect(self.play)
- window.pauseAction = window.playbackMenu.addAction(
-- QtGui.QPixmap(resourcespath + 'control_pause_blue.png'),
-+ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'control_pause_blue.png')),
- getMessage("pause-menu-label"))
- window.pauseAction.triggered.connect(self.pause)
- window.seekAction = window.playbackMenu.addAction(
-- QtGui.QPixmap(resourcespath + 'clock_go.png'),
-+ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'clock_go.png')),
- getMessage("seektime-menu-label"))
- window.seekAction.triggered.connect(self.seekPositionDialog)
- window.unseekAction = window.playbackMenu.addAction(
-- QtGui.QPixmap(resourcespath + 'arrow_undo.png'),
-+ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'arrow_undo.png')),
- getMessage("undoseek-menu-label"))
- window.unseekAction.triggered.connect(self.undoSeek)
-
-@@ -1705,17 +1705,17 @@ def populateMenubar(self, window):
-
- window.advancedMenu = QtWidgets.QMenu(getMessage("advanced-menu-label"), self)
- window.setoffsetAction = window.advancedMenu.addAction(
-- QtGui.QPixmap(resourcespath + 'timeline_marker.png'),
-+ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'timeline_marker.png')),
- getMessage("setoffset-menu-label"))
- window.setoffsetAction.triggered.connect(self.setOffset)
- window.setTrustedDomainsAction = window.advancedMenu.addAction(
-- QtGui.QPixmap(resourcespath + 'shield_edit.png'),
-+ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'shield_edit.png')),
- getMessage("settrusteddomains-menu-label"))
- window.setTrustedDomainsAction.triggered.connect(self.openSetTrustedDomainsDialog)
- window.createcontrolledroomAction = window.advancedMenu.addAction(
-- QtGui.QPixmap(resourcespath + 'page_white_key.png'), getMessage("createcontrolledroom-menu-label"))
-+ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'page_white_key.png')), getMessage("createcontrolledroom-menu-label"))
- window.createcontrolledroomAction.triggered.connect(self.createControlledRoom)
-- window.identifyascontroller = window.advancedMenu.addAction(QtGui.QPixmap(resourcespath + 'key_go.png'),
-+ window.identifyascontroller = window.advancedMenu.addAction(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'key_go.png')),
- getMessage("identifyascontroller-menu-label"))
- window.identifyascontroller.triggered.connect(self.identifyAsController)
-
-@@ -1725,7 +1725,7 @@ def populateMenubar(self, window):
-
- window.windowMenu = QtWidgets.QMenu(getMessage("window-menu-label"), self)
-
-- window.editroomsAction = window.windowMenu.addAction(QtGui.QPixmap(resourcespath + 'door_open_edit.png'), getMessage("roomlist-msgbox-label"))
-+ window.editroomsAction = window.windowMenu.addAction(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'door_open_edit.png')), getMessage("roomlist-msgbox-label"))
- window.editroomsAction.triggered.connect(self.openEditRoomsDialog)
- window.menuBar.addMenu(window.windowMenu)
-
-@@ -1743,18 +1743,18 @@ def populateMenubar(self, window):
- window.helpMenu = QtWidgets.QMenu(getMessage("help-menu-label"), self)
-
- window.userguideAction = window.helpMenu.addAction(
-- QtGui.QPixmap(resourcespath + 'help.png'),
-+ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'help.png')),
- getMessage("userguide-menu-label"))
- window.userguideAction.triggered.connect(self.openUserGuide)
- window.updateAction = window.helpMenu.addAction(
-- QtGui.QPixmap(resourcespath + 'application_get.png'),
-+ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'application_get.png')),
- getMessage("update-menu-label"))
- window.updateAction.triggered.connect(self.userCheckForUpdates)
-
- if not isMacOS():
- window.helpMenu.addSeparator()
- window.about = window.helpMenu.addAction(
-- QtGui.QPixmap(resourcespath + 'syncplay.png'),
-+ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'syncplay.png')),
- getMessage("about-menu-label"))
- else:
- window.about = window.helpMenu.addAction("&About")
-@@ -1835,16 +1835,16 @@ def changeAutoplayState(self, source=None):
- def updateReadyIcon(self):
- ready = self.readyPushButton.isChecked()
- if ready:
-- self.readyPushButton.setIcon(QtGui.QPixmap(resourcespath + 'tick_checkbox.png'))
-+ self.readyPushButton.setIcon(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'tick_checkbox.png')))
- else:
-- self.readyPushButton.setIcon(QtGui.QPixmap(resourcespath + 'empty_checkbox.png'))
-+ self.readyPushButton.setIcon(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'empty_checkbox.png')))
-
- def updateAutoPlayIcon(self):
- ready = self.autoplayPushButton.isChecked()
- if ready:
-- self.autoplayPushButton.setIcon(QtGui.QPixmap(resourcespath + 'tick_checkbox.png'))
-+ self.autoplayPushButton.setIcon(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'tick_checkbox.png')))
- else:
-- self.autoplayPushButton.setIcon(QtGui.QPixmap(resourcespath + 'empty_checkbox.png'))
-+ self.autoplayPushButton.setIcon(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'empty_checkbox.png')))
-
- def automaticUpdateCheck(self):
- currentDateTimeValue = QDateTime.currentDateTime()
-@@ -2060,7 +2060,7 @@ def __init__(self, passedBar=None):
- self.populateMenubar(self)
- self.addMainFrame(self)
- self.loadSettings()
-- self.setWindowIcon(QtGui.QPixmap(resourcespath + "syncplay.png"))
-+ self.setWindowIcon(QtGui.QIcon(QtGui.QPixmap(resourcespath + "syncplay.png")))
- self.setWindowFlags(self.windowFlags() & Qt.WindowCloseButtonHint & Qt.WindowMinimizeButtonHint & ~Qt.WindowContextHelpButtonHint)
- self.show()
- self.setAcceptDrops(True)
-
diff --git a/media-video/syncplay/files/syncplay-make-qpixmap-to-qicon-conversion-explicit2.patch b/media-video/syncplay/files/syncplay-make-qpixmap-to-qicon-conversion-explicit2.patch
new file mode 100644
index 000000000..85b61ea4d
--- /dev/null
+++ b/media-video/syncplay/files/syncplay-make-qpixmap-to-qicon-conversion-explicit2.patch
@@ -0,0 +1,176 @@
+From b0e018d0cda148ef8dba07857fcbe8d751800992 Mon Sep 17 00:00:00 2001
+From: Andrew Ammerlaan <andrewammerlaan@riseup.net>
+Date: Thu, 8 Oct 2020 08:47:44 +0200
+Subject: [PATCH] make conversion from QPixmap to QIcon explicit
+
+---
+ syncplay/ui/gui.py | 106 ++++++++++++++++++++++-----------------------
+ 1 file changed, 53 insertions(+), 53 deletions(-)
+
+diff --git a/syncplay/ui/gui.py b/syncplay/ui/gui.py
+index c59c5697..2a4bd1a5 100755
+--- a/syncplay/ui/gui.py
++++ b/syncplay/ui/gui.py
+@@ -1620,24 +1620,24 @@ def addPlaybackLayout(self, window):
+ window.playbackFrame.setLayout(window.playbackLayout)
+ window.seekInput = QtWidgets.QLineEdit()
+ window.seekInput.returnPressed.connect(self.seekFromButton)
+- window.seekButton = QtWidgets.QPushButton(QtGui.QPixmap(resourcespath + 'clock_go.png'), "")
++ window.seekButton = QtWidgets.QPushButton(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'clock_go.png')), "")
+ window.seekButton.setToolTip(getMessage("seektime-menu-label"))
+ window.seekButton.pressed.connect(self.seekFromButton)
+ window.seekInput.setText("0:00")
+ window.seekInput.setFixedWidth(60)
+ window.playbackLayout.addWidget(window.seekInput)
+ window.playbackLayout.addWidget(window.seekButton)
+- window.unseekButton = QtWidgets.QPushButton(QtGui.QPixmap(resourcespath + 'arrow_undo.png'), "")
++ window.unseekButton = QtWidgets.QPushButton(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'arrow_undo.png')), "")
+ window.unseekButton.setToolTip(getMessage("undoseek-menu-label"))
+ window.unseekButton.pressed.connect(self.undoSeek)
+
+ window.miscLayout = QtWidgets.QHBoxLayout()
+ window.playbackLayout.addWidget(window.unseekButton)
+- window.playButton = QtWidgets.QPushButton(QtGui.QPixmap(resourcespath + 'control_play_blue.png'), "")
++ window.playButton = QtWidgets.QPushButton(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'control_play_blue.png')), "")
+ window.playButton.setToolTip(getMessage("play-menu-label"))
+ window.playButton.pressed.connect(self.play)
+ window.playbackLayout.addWidget(window.playButton)
+- window.pauseButton = QtWidgets.QPushButton(QtGui.QPixmap(resourcespath + 'control_pause_blue.png'), "")
++ window.pauseButton = QtWidgets.QPushButton(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'control_pause_blue.png')), "")
+ window.pauseButton.setToolTip(getMessage("pause-menu-label"))
+ window.pauseButton.pressed.connect(self.pause)
+ window.playbackLayout.addWidget(window.pauseButton)
+@@ -1657,13 +1657,13 @@ def populateMenubar(self, window):
+ # File menu
+
+ window.fileMenu = QtWidgets.QMenu(getMessage("file-menu-label"), self)
+- window.openAction = window.fileMenu.addAction(QtGui.QPixmap(resourcespath + 'folder_explore.png'),
++ window.openAction = window.fileMenu.addAction(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'folder_explore.png')),
+ getMessage("openmedia-menu-label"))
+ window.openAction.triggered.connect(self.browseMediapath)
+- window.openAction = window.fileMenu.addAction(QtGui.QPixmap(resourcespath + 'world_explore.png'),
++ window.openAction = window.fileMenu.addAction(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'world_explore.png')),
+ getMessage("openstreamurl-menu-label"))
+ window.openAction.triggered.connect(self.promptForStreamURL)
+- window.openAction = window.fileMenu.addAction(QtGui.QPixmap(resourcespath + 'film_folder_edit.png'),
++ window.openAction = window.fileMenu.addAction(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'film_folder_edit.png')),
+ getMessage("setmediadirectories-menu-label"))
+ window.openAction.triggered.connect(self.openSetMediaDirectoriesDialog)
+
+@@ -1671,7 +1671,7 @@ def populateMenubar(self, window):
+ if isMacOS():
+ window.exitAction.setMenuRole(QtWidgets.QAction.QuitRole)
+ else:
+- window.exitAction.setIcon(QtGui.QPixmap(resourcespath + 'cross.png'))
++ window.exitAction.setIcon(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'cross.png')))
+ window.exitAction.triggered.connect(self.exitSyncplay)
+
+ if(window.editMenu is not None):
+@@ -1683,19 +1683,19 @@ def populateMenubar(self, window):
+
+ window.playbackMenu = QtWidgets.QMenu(getMessage("playback-menu-label"), self)
+ window.playAction = window.playbackMenu.addAction(
+- QtGui.QPixmap(resourcespath + 'control_play_blue.png'),
++ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'control_play_blue.png')),
+ getMessage("play-menu-label"))
+ window.playAction.triggered.connect(self.play)
+ window.pauseAction = window.playbackMenu.addAction(
+- QtGui.QPixmap(resourcespath + 'control_pause_blue.png'),
++ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'control_pause_blue.png')),
+ getMessage("pause-menu-label"))
+ window.pauseAction.triggered.connect(self.pause)
+ window.seekAction = window.playbackMenu.addAction(
+- QtGui.QPixmap(resourcespath + 'clock_go.png'),
++ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'clock_go.png')),
+ getMessage("seektime-menu-label"))
+ window.seekAction.triggered.connect(self.seekPositionDialog)
+ window.unseekAction = window.playbackMenu.addAction(
+- QtGui.QPixmap(resourcespath + 'arrow_undo.png'),
++ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'arrow_undo.png')),
+ getMessage("undoseek-menu-label"))
+ window.unseekAction.triggered.connect(self.undoSeek)
+
+@@ -1705,17 +1705,17 @@ def populateMenubar(self, window):
+
+ window.advancedMenu = QtWidgets.QMenu(getMessage("advanced-menu-label"), self)
+ window.setoffsetAction = window.advancedMenu.addAction(
+- QtGui.QPixmap(resourcespath + 'timeline_marker.png'),
++ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'timeline_marker.png')),
+ getMessage("setoffset-menu-label"))
+ window.setoffsetAction.triggered.connect(self.setOffset)
+ window.setTrustedDomainsAction = window.advancedMenu.addAction(
+- QtGui.QPixmap(resourcespath + 'shield_edit.png'),
++ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'shield_edit.png')),
+ getMessage("settrusteddomains-menu-label"))
+ window.setTrustedDomainsAction.triggered.connect(self.openSetTrustedDomainsDialog)
+ window.createcontrolledroomAction = window.advancedMenu.addAction(
+- QtGui.QPixmap(resourcespath + 'page_white_key.png'), getMessage("createcontrolledroom-menu-label"))
++ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'page_white_key.png')), getMessage("createcontrolledroom-menu-label"))
+ window.createcontrolledroomAction.triggered.connect(self.createControlledRoom)
+- window.identifyascontroller = window.advancedMenu.addAction(QtGui.QPixmap(resourcespath + 'key_go.png'),
++ window.identifyascontroller = window.advancedMenu.addAction(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'key_go.png')),
+ getMessage("identifyascontroller-menu-label"))
+ window.identifyascontroller.triggered.connect(self.identifyAsController)
+
+@@ -1725,7 +1725,7 @@ def populateMenubar(self, window):
+
+ window.windowMenu = QtWidgets.QMenu(getMessage("window-menu-label"), self)
+
+- window.editroomsAction = window.windowMenu.addAction(QtGui.QPixmap(resourcespath + 'door_open_edit.png'), getMessage("roomlist-msgbox-label"))
++ window.editroomsAction = window.windowMenu.addAction(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'door_open_edit.png')), getMessage("roomlist-msgbox-label"))
+ window.editroomsAction.triggered.connect(self.openEditRoomsDialog)
+ window.menuBar.addMenu(window.windowMenu)
+
+@@ -1743,18 +1743,18 @@ def populateMenubar(self, window):
+ window.helpMenu = QtWidgets.QMenu(getMessage("help-menu-label"), self)
+
+ window.userguideAction = window.helpMenu.addAction(
+- QtGui.QPixmap(resourcespath + 'help.png'),
++ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'help.png')),
+ getMessage("userguide-menu-label"))
+ window.userguideAction.triggered.connect(self.openUserGuide)
+ window.updateAction = window.helpMenu.addAction(
+- QtGui.QPixmap(resourcespath + 'application_get.png'),
++ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'application_get.png')),
+ getMessage("update-menu-label"))
+ window.updateAction.triggered.connect(self.userCheckForUpdates)
+
+ if not isMacOS():
+ window.helpMenu.addSeparator()
+ window.about = window.helpMenu.addAction(
+- QtGui.QPixmap(resourcespath + 'syncplay.png'),
++ QtGui.QIcon(QtGui.QPixmap(resourcespath + 'syncplay.png')),
+ getMessage("about-menu-label"))
+ else:
+ window.about = window.helpMenu.addAction("&About")
+@@ -1835,16 +1835,16 @@ def changeAutoplayState(self, source=None):
+ def updateReadyIcon(self):
+ ready = self.readyPushButton.isChecked()
+ if ready:
+- self.readyPushButton.setIcon(QtGui.QPixmap(resourcespath + 'tick_checkbox.png'))
++ self.readyPushButton.setIcon(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'tick_checkbox.png')))
+ else:
+- self.readyPushButton.setIcon(QtGui.QPixmap(resourcespath + 'empty_checkbox.png'))
++ self.readyPushButton.setIcon(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'empty_checkbox.png')))
+
+ def updateAutoPlayIcon(self):
+ ready = self.autoplayPushButton.isChecked()
+ if ready:
+- self.autoplayPushButton.setIcon(QtGui.QPixmap(resourcespath + 'tick_checkbox.png'))
++ self.autoplayPushButton.setIcon(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'tick_checkbox.png')))
+ else:
+- self.autoplayPushButton.setIcon(QtGui.QPixmap(resourcespath + 'empty_checkbox.png'))
++ self.autoplayPushButton.setIcon(QtGui.QIcon(QtGui.QPixmap(resourcespath + 'empty_checkbox.png')))
+
+ def automaticUpdateCheck(self):
+ currentDateTimeValue = QDateTime.currentDateTime()
+@@ -2060,7 +2060,7 @@ def __init__(self, passedBar=None):
+ self.populateMenubar(self)
+ self.addMainFrame(self)
+ self.loadSettings()
+- self.setWindowIcon(QtGui.QPixmap(resourcespath + "syncplay.png"))
++ self.setWindowIcon(QtGui.QIcon(QtGui.QPixmap(resourcespath + "syncplay.png")))
+ self.setWindowFlags(self.windowFlags() & Qt.WindowCloseButtonHint & Qt.WindowMinimizeButtonHint & ~Qt.WindowContextHelpButtonHint)
+ self.show()
+ self.setAcceptDrops(True)
+
diff --git a/media-video/syncplay/syncplay-1.6.6_beta2.ebuild b/media-video/syncplay/syncplay-1.6.6.ebuild
index 30712b366..6c85c3d38 100644
--- a/media-video/syncplay/syncplay-1.6.6_beta2.ebuild
+++ b/media-video/syncplay/syncplay-1.6.6.ebuild
@@ -8,11 +8,9 @@ DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1 optfeature xdg
-MYPV="${PV/_beta/-Beta}"
-
DESCRIPTION="Client/server to synchronize media playback"
HOMEPAGE="https://github.com/Syncplay/syncplay https://syncplay.pl"
-SRC_URI="https://github.com/${PN^}/${PN}/archive/${MYPV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/${PN^}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
@@ -36,12 +34,11 @@ RDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-change-alignment-operator.patch"
"${FILESDIR}/${PN}-make-qpixmap-to-qicon-conversion-explicit.patch"
+ "${FILESDIR}/${PN}-make-qpixmap-to-qicon-conversion-explicit2.patch"
"${FILESDIR}/${PN}-use-lambda-to-connect-behind-wrapper.patch"
"${FILESDIR}/${PN}-allow-PyQt5.patch"
)
-S="${WORKDIR}/${PN}-${MYPV}"
-
python_install() {
local MY_MAKEOPTS=( DESTDIR="${D}" PREFIX=/usr )
if use client; then