aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2019-05-14 00:54:49 +0900
committerWilliam Breathitt Gray <vilhelm.gray@gmail.com>2019-05-16 10:42:55 +0900
commit96f132b5e870bd32466754b6fcee63bd2a9ca5b4 (patch)
tree9b19cea9d2e0b972e6b5dd0da4affd881d218d6c
parentgames-fps/gzdoom: Fix makefiles for bundled libraries (diff)
downloadguru-96f132b5e870bd32466754b6fcee63bd2a9ca5b4.tar.gz
guru-96f132b5e870bd32466754b6fcee63bd2a9ca5b4.tar.bz2
guru-96f132b5e870bd32466754b6fcee63bd2a9ca5b4.zip
games-fps/chocolate-doom: New package
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
-rw-r--r--games-fps/chocolate-doom/Manifest1
-rw-r--r--games-fps/chocolate-doom/chocolate-doom-3.0.0.ebuild48
-rw-r--r--games-fps/chocolate-doom/metadata.xml16
3 files changed, 65 insertions, 0 deletions
diff --git a/games-fps/chocolate-doom/Manifest b/games-fps/chocolate-doom/Manifest
new file mode 100644
index 000000000..414ec2285
--- /dev/null
+++ b/games-fps/chocolate-doom/Manifest
@@ -0,0 +1 @@
+DIST chocolate-doom-3.0.0.tar.gz 2495591 BLAKE2B 11989b4b4458098af63c4b89a73552a8bb43c22077d358770b0e89e1b816950b92630592dcb5b4a782ccf673951b7e3d8503bc517577fe59d052d8b4f3f125e1 SHA512 41f235c0d84ef21070636ad0610e97898dfd366fae7f9244bd2aebf8974db98dcf55f70bcab2f93589b9bf31dd421db32e8af88e0f8e0a655d2b9f1d4ead2afd
diff --git a/games-fps/chocolate-doom/chocolate-doom-3.0.0.ebuild b/games-fps/chocolate-doom/chocolate-doom-3.0.0.ebuild
new file mode 100644
index 000000000..97c1786ad
--- /dev/null
+++ b/games-fps/chocolate-doom/chocolate-doom-3.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="Chocolate Doom - a Doom source port that is minimalist and historically accurate"
+HOMEPAGE="https://www.chocolate-doom.org"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion libsamplerate png python timidity +vorbis"
+
+DEPEND="
+ media-libs/libsdl2
+ media-libs/sdl2-mixer[timidity?,vorbis?]
+ media-libs/sdl2-net
+ libsamplerate? ( media-libs/libsamplerate )
+ png? ( media-libs/libpng:= )"
+RDEPEND="
+ ${DEPEND}
+ bash-completion? ( app-shells/bash-completion )
+ python? (
+ dev-lang/python
+ dev-python/pillow
+ )"
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${P}/docs" \
+ $(use_with libsamplerate) \
+ $(use_with png libpng)
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}
diff --git a/games-fps/chocolate-doom/metadata.xml b/games-fps/chocolate-doom/metadata.xml
new file mode 100644
index 000000000..b236c975b
--- /dev/null
+++ b/games-fps/chocolate-doom/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ Chocolate Doom aims to accurately reproduce the original DOS version of Doom and other games based on the Doom engine in a form that can be run on modern computers.
+ </longdescription>
+ <maintainer type="person">
+ <email>vilhelm.gray@gmail.com</email>
+ <name>William Breathitt Gray</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/chocolate-doom/chocolate-doom/issues</bugs-to>
+ <doc lang="en">https://www.chocolate-doom.org</doc>
+ <remote-id type="github">chocolate-doom/chocolate-doom</remote-id>
+ </upstream>
+</pkgmetadata>