aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2023-02-28 16:45:14 +0500
committerDenis Reva <denis7774@gmail.com>2023-02-28 17:56:54 +0500
commit055316fea12384d864d0b45037242eb6dfdc5ba6 (patch)
tree9b5cc762d502f89bce75d88cb241e61c75f436ab
parentwww-apps/gotosocial: fix docs deps (diff)
downloadguru-055316fe.tar.gz
guru-055316fe.tar.bz2
guru-055316fe.zip
dev-cpp/fizz: Updated and unorphaned
Signed-off-by: Denis Reva <denis7774@gmail.com>
-rw-r--r--dev-cpp/fizz/Manifest1
-rw-r--r--dev-cpp/fizz/fizz-2023.02.06.00.ebuild48
-rw-r--r--dev-cpp/fizz/metadata.xml18
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-cpp/fizz/Manifest b/dev-cpp/fizz/Manifest
new file mode 100644
index 000000000..9dedb363e
--- /dev/null
+++ b/dev-cpp/fizz/Manifest
@@ -0,0 +1 @@
+DIST fizz-2023.02.06.00.tar.gz 649362 BLAKE2B a77f90a9d8eca9fb934aacbc903f5af702d8e22b33b0884c742dd40b51f1993f2015758e62ee815eed0f3570a608768914d4f2077d9da0a69c50e78270a64085 SHA512 88cd3d3198442ea0cd2d5098c53fef55d9a7a6b998ddeb6e2e32f7dd26827682dabe1def9bef6f321da5dbb8c48675cb3045a20733fcc7191cc7b81248d8176e
diff --git a/dev-cpp/fizz/fizz-2023.02.06.00.ebuild b/dev-cpp/fizz/fizz-2023.02.06.00.ebuild
new file mode 100644
index 000000000..597703566
--- /dev/null
+++ b/dev-cpp/fizz/fizz-2023.02.06.00.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++14 implementation of the TLS-1.3 standard"
+HOMEPAGE="https://github.com/facebookincubator/fizz"
+SRC_URI="https://github.com/facebookincubator/fizz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples test"
+
+RDEPEND="
+ >=dev-cpp/folly-${PV}:=
+ dev-cpp/gflags
+ dev-cpp/glog
+ dev-libs/double-conversion
+ dev-libs/libevent
+ dev-libs/libfmt
+ dev-libs/libsodium
+ dev-libs/openssl:0=
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( >=dev-cpp/gtest-1.11.0 )
+"
+
+RESTRICT="!test? ( test )"
+CMAKE_USE_DIR="${S}/fizz"
+
+src_prepare() {
+ cmake_src_prepare
+ sed -i '/Sodium/d' fizz/cmake/fizz-config.cmake.in || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(usex examples)
+ -DBUILD_TESTS=$(usex test)
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-cpp/fizz/metadata.xml b/dev-cpp/fizz/metadata.xml
new file mode 100644
index 000000000..7e92afec0
--- /dev/null
+++ b/dev-cpp/fizz/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>denis7774@gmail.com</email>
+ <name>Denis Reva</name>
+ <description>rarogcmex</description>
+ </maintainer>
+ <longdescription lang="en">
+The core protocol implementations are in ClientProtocol and ServerProtocol. FizzClientContext and FizzServerContext provide configuration options. FizzClient and FizzServer (which both inherit from FizzBase) provide applications with an interface to interact with the state machine. FizzClient/FizzServer receives events from the application layer, invokes the correct event handler, and invokes the application ActionVisitor to process the actions.
+
+AsyncFizzClient and AsyncFizzServer provide implementations of the folly AsyncTransportWrapper interface. They own an underlying transport (for example AsyncSocket) and perform the TLS handshake and encrypt/decrypt application data.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/facebookincubator/fizz/issues</bugs-to>
+ <remote-id type="github">facebookincubator/fizz</remote-id>
+ </upstream>
+</pkgmetadata>