aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-02-27 01:56:26 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-02-27 03:41:36 +0500
commit10778355149281af1df9860d966869a4d6aaf939 (patch)
treea2dc079cfca229b5d23dfa1a4d53585d7f2af82e
parentdev-python/itemadapter: drop 0.4.0 (diff)
downloadguru-10778355149281af1df9860d966869a4d6aaf939.tar.gz
guru-10778355149281af1df9860d966869a4d6aaf939.tar.bz2
guru-10778355149281af1df9860d966869a4d6aaf939.zip
dev-python/opentypespec: add 1.9.1, drop 1.8.4
Closes: https://bugs.gentoo.org/897480 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--dev-python/opentypespec/Manifest2
-rw-r--r--dev-python/opentypespec/opentypespec-1.8.4.ebuild21
-rw-r--r--dev-python/opentypespec/opentypespec-1.9.1.ebuild20
3 files changed, 21 insertions, 22 deletions
diff --git a/dev-python/opentypespec/Manifest b/dev-python/opentypespec/Manifest
index 31d20321e..79108035e 100644
--- a/dev-python/opentypespec/Manifest
+++ b/dev-python/opentypespec/Manifest
@@ -1 +1 @@
-DIST opentypespec-1.8.4.tar.gz 15963 BLAKE2B 3d796ffa37f7a617a3be8d5a323fbe8f88e57e05aa031edfe1e48115a65526585d522a2426ed5d5ad970621d0cc301238bed8ac0c2beaab526f0b8679572e2ef SHA512 30c96322901ae99c3f8f71d7621660d7273b0ced60c86a253c573c32d491ce1ef6da750106f4aa8fdd005583be6fc31ef9513c301bfe0a6a39e1b6634ede1e9d
+DIST opentypespec-1.9.1.tar.gz 22450 BLAKE2B 53b426f86c1210460f94c8f830987c0ecf1d560e57ec07e890bb359f20b66293357784f2de652a441b17e92c4a031d13f8540b73d16669715c5827a2464a27fc SHA512 2dc2305fe3b03ef5067effe599694c4e64826b44821c0e2c149c5e3c749932c79afba35f81d58b1435c2ddb3422d81625fae0420b7e9e6c5ed36bb667a5bedb3
diff --git a/dev-python/opentypespec/opentypespec-1.8.4.ebuild b/dev-python/opentypespec/opentypespec-1.8.4.ebuild
deleted file mode 100644
index 78e4d6eee..000000000
--- a/dev-python/opentypespec/opentypespec-1.8.4.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bezier manipulation library"
-HOMEPAGE="https://github.com/simoncozens/opentypespec-py"
-SRC_URI="https://github.com/simoncozens/opentypespec-py/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-py-${PV}"
-
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64"
-SLOT="0"
-
-RESTRICT="test" #https://github.com/simoncozens/opentypespec-py/issues/1
-
-distutils_enable_tests setup.py
diff --git a/dev-python/opentypespec/opentypespec-1.9.1.ebuild b/dev-python/opentypespec/opentypespec-1.9.1.ebuild
new file mode 100644
index 000000000..72216aa3f
--- /dev/null
+++ b/dev-python/opentypespec/opentypespec-1.9.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Data derived from the OpenType specification"
+HOMEPAGE="
+ https://pypi.org/project/opentypespec/
+ https://github.com/simoncozens/opentypespec-py
+"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+SLOT="0"
+
+distutils_enable_tests pytest