aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@protonmail.com>2020-07-28 12:41:40 +0200
committerMaciej Barć <xgqt@protonmail.com>2020-07-28 12:41:40 +0200
commit3812f7154f2b2c0708a0432041c03a5b00e4d5d6 (patch)
tree38191e72154ad3f451d4abfc2bef25c1185ef10e
parentnet-misc/gallery-dl: fix typo (diff)
downloadguru-3812f7154f2b2c0708a0432041c03a5b00e4d5d6.tar.gz
guru-3812f7154f2b2c0708a0432041c03a5b00e4d5d6.tar.bz2
guru-3812f7154f2b2c0708a0432041c03a5b00e4d5d6.zip
net-misc/gallery-dl: use optfeature
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Maciej Barć <xgqt@protonmail.com>
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.14.3.ebuild8
-rw-r--r--net-misc/gallery-dl/gallery-dl-9999.ebuild8
2 files changed, 10 insertions, 6 deletions
diff --git a/net-misc/gallery-dl/gallery-dl-1.14.3.ebuild b/net-misc/gallery-dl/gallery-dl-1.14.3.ebuild
index 9e9053bfa..edcab4bdc 100644
--- a/net-misc/gallery-dl/gallery-dl-1.14.3.ebuild
+++ b/net-misc/gallery-dl/gallery-dl-1.14.3.ebuild
@@ -45,7 +45,9 @@ src_compile() {
}
pkg_postinst() {
- elog "Optional dependencies:"
- elog "media-video/ffmpeg - for Pixiv Ugoira to WebM conversion"
- elog "net-misc/youtube-dl - for video downloads"
+ elog "To get additional features, some optional runtime dependencies"
+ elog "may be installed:"
+ elog ""
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
}
diff --git a/net-misc/gallery-dl/gallery-dl-9999.ebuild b/net-misc/gallery-dl/gallery-dl-9999.ebuild
index 9e9053bfa..edcab4bdc 100644
--- a/net-misc/gallery-dl/gallery-dl-9999.ebuild
+++ b/net-misc/gallery-dl/gallery-dl-9999.ebuild
@@ -45,7 +45,9 @@ src_compile() {
}
pkg_postinst() {
- elog "Optional dependencies:"
- elog "media-video/ffmpeg - for Pixiv Ugoira to WebM conversion"
- elog "net-misc/youtube-dl - for video downloads"
+ elog "To get additional features, some optional runtime dependencies"
+ elog "may be installed:"
+ elog ""
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
}