aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-04-28 19:24:56 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-04-28 19:24:56 +0200
commitbfad6edf10cacb4d3e22994831726e5aff52583d (patch)
tree6f3ad474f4b09bbef6200f443e3eeb7712c64595
parentdev-python/pytest-toolbox: Numerous useful plugins for pytest (diff)
downloadguru-bfad6edf10cacb4d3e22994831726e5aff52583d.tar.gz
guru-bfad6edf10cacb4d3e22994831726e5aff52583d.tar.bz2
guru-bfad6edf10cacb4d3e22994831726e5aff52583d.zip
dev-python/watchgod: Simple, modern file watching and code reload
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--dev-python/watchgod/Manifest1
-rw-r--r--dev-python/watchgod/metadata.xml13
-rw-r--r--dev-python/watchgod/watchgod-0.6.ebuild27
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/watchgod/Manifest b/dev-python/watchgod/Manifest
new file mode 100644
index 000000000..50084a1c8
--- /dev/null
+++ b/dev-python/watchgod/Manifest
@@ -0,0 +1 @@
+DIST watchgod-0.6.tar.gz 13261 BLAKE2B 6cf32f6ea467fd4cdb3b0da30aa56bfbf3909adb25d2d44621733c665dccf77b203e99049655793a674f688f3adc8519d8e95156932ccfb9dceda28888bac115 SHA512 1eaa0febc4ba8b1e4bbd6e7bae8f2312c2eeaae395ebbf76953fdf937d4eda06bad818574000d6b96abfefe391affb5d007426bbf7867578293729decc6b61fb
diff --git a/dev-python/watchgod/metadata.xml b/dev-python/watchgod/metadata.xml
new file mode 100644
index 000000000..a5241af82
--- /dev/null
+++ b/dev-python/watchgod/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">samuelcolvin/watchgod</remote-id>
+ <remote-id type="pypi">watchgod</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/watchgod/watchgod-0.6.ebuild b/dev-python/watchgod/watchgod-0.6.ebuild
new file mode 100644
index 000000000..7148f41a1
--- /dev/null
+++ b/dev-python/watchgod/watchgod-0.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Simple, modern file watching and code reload"
+HOMEPAGE="https://github.com/samuelcolvin/watchgod"
+SRC_URI="https://github.com/samuelcolvin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DEPEND="test? (
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-toolbox[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest