aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-06-30 17:12:15 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-06-30 17:13:32 +0200
commitcca5952a0d3f9ef96cfd0e4bbae6201ed5589268 (patch)
tree4806da902ab32db32d4fdf5ca1478adbfb324bc5
parentapp-misc/watchexec: fix test file for release build (diff)
downloadguru-cca5952a0d3f9ef96cfd0e4bbae6201ed5589268.tar.gz
guru-cca5952a0d3f9ef96cfd0e4bbae6201ed5589268.tar.bz2
guru-cca5952a0d3f9ef96cfd0e4bbae6201ed5589268.zip
dev-cpp/parallel-hashmap: restrict tests
Closes: https://bugs.gentoo.org/855329 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild b/dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild
index 036b306d5..46dd6b355 100644
--- a/dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild
+++ b/dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild
@@ -21,7 +21,9 @@ CDEPEND="dev-libs/cereal"
DEPEND="test? ( ${CDEPEND} )"
RDEPEND="${CDEPEND}"
-RESTRICT="!test? ( test )"
+# tests will download gtest, not trivial to use the system one
+# https://github.com/greg7mdp/parallel-hashmap/issues/154
+RESTRICT="test"
src_compile() {
mycmakeargs=(