aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuje Mihanović <duje.mihanovic@skole.hr>2022-05-24 21:09:37 +0200
committerDuje Mihanović <duje.mihanovic@skole.hr>2022-05-24 21:10:47 +0200
commite1e9c0a70d3424971180305144380103efa437c1 (patch)
treeafaf097048842c376fa807af43ef4056a766cadb
parentsys-process/snooze: minor QA: remove PN from metadata vars (diff)
downloadguru-e1e9c0a70d3424971180305144380103efa437c1.tar.gz
guru-e1e9c0a70d3424971180305144380103efa437c1.tar.bz2
guru-e1e9c0a70d3424971180305144380103efa437c1.zip
dev-util/pmbootstrap: add 1.44.1
Signed-off-by: Duje Mihanović <duje.mihanovic@skole.hr>
-rw-r--r--dev-util/pmbootstrap/Manifest1
-rw-r--r--dev-util/pmbootstrap/pmbootstrap-1.44.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/pmbootstrap/Manifest b/dev-util/pmbootstrap/Manifest
index 9b2589af2..b5d01ee27 100644
--- a/dev-util/pmbootstrap/Manifest
+++ b/dev-util/pmbootstrap/Manifest
@@ -1 +1,2 @@
DIST pmbootstrap-1.43.1.tar.gz 225811 BLAKE2B d8e5d74510692f65e1430be9d813c23c95c4e8b44212c21ef01747264333a59cb158fb7f03866ca28d907b2d9ab927bfa9dd347bed7462fab6c64b03b9a629cf SHA512 96ba36dba211eacca44afae2c7009fc3e784e0067547406f9640eda311e3331adc54a81ebecefdf3238096e7a156dd3e56fc5b2864c28810c0526ab3efb64c15
+DIST pmbootstrap-1.44.1.tar.gz 225898 BLAKE2B 0dd8ea621c7ece8cd7f331d06dd85bde6b38c08bcadd8b0bc6d364855bef7204007988d79992b4ecc8d15e89f1f3917aa0104e81f93ab88e62392da6c96a0bcc SHA512 05499bea2d880f7c8ec3e4bf87b819186448eb99855989d88dc7fa320c71b142461e0679d6089cb06cd3f3b887da389e924d03b20e5f9c339b1ef7610b37b2cf
diff --git a/dev-util/pmbootstrap/pmbootstrap-1.44.1.ebuild b/dev-util/pmbootstrap/pmbootstrap-1.44.1.ebuild
new file mode 100644
index 000000000..e4a1d1f11
--- /dev/null
+++ b/dev-util/pmbootstrap/pmbootstrap-1.44.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit python-r1 distutils-r1 linux-info
+
+DESCRIPTION="Helper tool for developing and building postmarketOS"
+HOMEPAGE="https://postmarketos.org/"
+
+SRC_URI="https://files.pythonhosted.org/packages/source/p/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+
+# According to upstream README either x86, amd64 or arm64 are required. I
+# wrote down all other arches because if I just did -* without adding x86 and
+# arm64 keywords it would seem like the package only works on amd64, but I can't
+# keyword x86 and arm64 because I can't test these.
+KEYWORDS="-alpha ~amd64 -arm -hppa -ia64 -ppc -ppc64 -riscv -sparc"
+# Tests are disabled because they require the pmaports repository (containing
+# postmarketOS APKBUILDs) to be cloned at runtime.
+RESTRICT="mirror test"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_pretend() {
+ if kernel_is -lt 3 17 0; then
+ eerror "pmbootstrap requires Linux 3.17 or greater."
+ die
+ fi
+}