aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-05-01 13:15:33 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-05-01 13:15:33 +0200
commit83c160c7312faa12173411c4dc652d61c8115d5d (patch)
tree4eef70b7d0c867f6a022e56df99cbd8a0c2cef5b /README.md
parentdev-python/doxypypy: remove python 8 compatibility (diff)
downloadguru-83c160c7312faa12173411c4dc652d61c8115d5d.tar.gz
guru-83c160c7312faa12173411c4dc652d61c8115d5d.tar.bz2
guru-83c160c7312faa12173411c4dc652d61c8115d5d.zip
README: Fixup gentoo repo location variable
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'README.md')
-rw-r--r--README.md2
1 files changed, 1 insertions, 1 deletions
diff --git a/README.md b/README.md
index 64b922c..a652cbe 100644
--- a/README.md
+++ b/README.md
@@ -92,7 +92,7 @@ String variables should be quoted (e.g. not `$P` or `${P}` but `"${P}"`). `repom
- #### Undesirable/Deprecated dependencies
-Sometimes a upstream lists dependencies which are considered deprecated. If possible, packages should **not** depend on these deprecated dependencies. Reasons a dependency might be deprecated is that it is too old, unmaintained, or the features it adds are not useful to Gentoo. You can find an overview of the currently deprecated dependencies and the reason they are deprecated in `${Gentoo_repo_dir}/profiles/package.deprecated`. `repoman -dx full` will warn you if your package depends on a deprecated dependency.
+Sometimes a upstream lists dependencies which are considered deprecated. If possible, packages should **not** depend on these deprecated dependencies. Reasons a dependency might be deprecated is that it is too old, unmaintained, or the features it adds are not useful to Gentoo. You can find an overview of the currently deprecated dependencies and the reason they are deprecated in `$(portageq get_repo_path / gentoo)/profiles/package.deprecated`. `repoman -dx full` will warn you if your package depends on a deprecated dependency.
For Python packages there are some additional (test) dependencies that are considered undesirable or not useful, but are not considered deprecated. You can find an overview of those [here](https://dev.gentoo.org/~mgorny/python-guide/distutils.html#enabling-tests).