aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Postiglione <andrea.postiglione@gmail.com>2020-08-14 21:40:53 +0200
committerAndrea Postiglione <andrea.postiglione@gmail.com>2020-08-14 21:40:53 +0200
commitbc6b76c53ce768f2651581738ed6619b3b7f9e00 (patch)
tree1d4452df9d2408c8560bff506da779d2da637c9b /app-admin/customrescuecd-x86
parentapp-admin/customrescuecd-x86_64 : initial ebuild (diff)
downloadguru-bc6b76c53ce768f2651581738ed6619b3b7f9e00.tar.gz
guru-bc6b76c53ce768f2651581738ed6619b3b7f9e00.tar.bz2
guru-bc6b76c53ce768f2651581738ed6619b3b7f9e00.zip
app-admin/customrescuecd-x86: initial ebuild
Signed-off-by: Andrea Postiglione <andrea.postiglione@gmail.com>
Diffstat (limited to 'app-admin/customrescuecd-x86')
-rw-r--r--app-admin/customrescuecd-x86/Manifest1
-rw-r--r--app-admin/customrescuecd-x86/customrescuecd-x86-0.3.1.ebuild55
-rw-r--r--app-admin/customrescuecd-x86/metadata.xml19
3 files changed, 75 insertions, 0 deletions
diff --git a/app-admin/customrescuecd-x86/Manifest b/app-admin/customrescuecd-x86/Manifest
new file mode 100644
index 000000000..047efe18f
--- /dev/null
+++ b/app-admin/customrescuecd-x86/Manifest
@@ -0,0 +1 @@
+DIST CUSTOMRESCUECD-x86-0.3.1.iso 1426063360 BLAKE2B 8116b657aed9f5fb9ac0d56f6284bc45a4e050ad7e84cd4cb7c5217b07c9151c82776589aefa3c030cf766106bca7948d48cde2055c408c4e32ea081297b6117 SHA512 3aa0d2ab54920a19046fc1038313e01a99287301b06f25b1346c54d680c4ca2395e9c9010b3299cdc94a0198ec0f63209d09a1d086243e3b82216e7f4d63e0e6
diff --git a/app-admin/customrescuecd-x86/customrescuecd-x86-0.3.1.ebuild b/app-admin/customrescuecd-x86/customrescuecd-x86-0.3.1.ebuild
new file mode 100644
index 000000000..4c3a5f629
--- /dev/null
+++ b/app-admin/customrescuecd-x86/customrescuecd-x86-0.3.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="CUSTOMRESCUECD-x86"
+DESCRIPTION="A system rescue cd or usbstick for desktop and server based on gentoo"
+HOMEPAGE="https://sourceforge.net/projects/customrescuecd"
+SRC_URI="mirror://sourceforge/customrescuecd/"${MY_P}"-"${PV}".iso"
+
+LICENSE="GPL-3"
+SLOT="${PV}"
+KEYWORDS="~x86"
+RESTRICT="bindist mirror"
+
+S=${WORKDIR}
+
+src_unpack() { :; }
+
+src_install() {
+ insinto "/usr/share/${PN%-*}"
+ doins "${DISTDIR}/${MY_P}-${PV}.iso"
+}
+
+pkg_postinst() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # no version newer than ours? we're the newest!
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ ln -f -s -v "${MY_P}-${PV}.iso" "${f}" || die
+ fi
+}
+
+pkg_postrm() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # if there is no version newer than ours installed
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ # and we are truly and completely uninstalled...
+ if [[ ! ${REPLACED_BY_VERSION} ]]; then
+ # then find an older version to set the symlink to
+ local newest_version=$(best_version "<${CATEGORY}/${PF}")
+
+ if [[ ${newest_version} ]]; then
+ # update the symlink
+ ln -f -s -v "${newest_version%-r*}.iso" "${f}" || die
+ else
+ # last version removed? clean up the symlink
+ rm -v "${f}" || die
+ # and the parent directory
+ rmdir "${f%/*}" || die
+ fi
+ fi
+ fi
+}
diff --git a/app-admin/customrescuecd-x86/metadata.xml b/app-admin/customrescuecd-x86/metadata.xml
new file mode 100644
index 000000000..47af661a8
--- /dev/null
+++ b/app-admin/customrescuecd-x86/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrea.postiglione@gmail.com</email>
+ <name>Andrea Postiglione</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <use>
+ <flag name="isohybrid">
+ Pass downloaded images through isohybrid in order to make it
+ possible to copy them directly to USB media and boot (requires
+ <pkg>sys-boot/syslinux</pkg> at build time).
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">customrescuecd</remote-id>
+ </upstream>
+</pkgmetadata>