aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-02 22:49:50 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-02 22:49:50 +0100
commitb21e21549b3f2d3988c3711fa8b139ba6b02cb77 (patch)
tree8f8ce5276dc0235a4111ada1ebc64169387e8b2b /app-misc/mat2
parentmedia-video/vidify: iherit xdg instead of xdg-utils (diff)
downloadguru-b21e21549b3f2d3988c3711fa8b139ba6b02cb77.tar.gz
guru-b21e21549b3f2d3988c3711fa8b139ba6b02cb77.tar.bz2
guru-b21e21549b3f2d3988c3711fa8b139ba6b02cb77.zip
app-misc/mat2: Version bump 0.10.1
Fixed test? in rdepend, repoman complains about that Added DISTUTILS_USE_SETUPTOOLS=rdepend, cause emerge complained about that Added py3.8 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'app-misc/mat2')
-rw-r--r--app-misc/mat2/Manifest2
-rw-r--r--app-misc/mat2/mat2-0.10.1.ebuild (renamed from app-misc/mat2/mat2-0.10.0.ebuild)24
2 files changed, 14 insertions, 12 deletions
diff --git a/app-misc/mat2/Manifest b/app-misc/mat2/Manifest
index edb62adb1e..9a3e440e22 100644
--- a/app-misc/mat2/Manifest
+++ b/app-misc/mat2/Manifest
@@ -1 +1 @@
-DIST mat2-0.10.0.tar.gz 5720611 BLAKE2B 3aeb1b5fb1e5b39d5a59e84de48a1fefed8afff31d7ae2827324b9d54eab8a95f28f0e1de94d6c96ba250249531782f4a2cff4a82fdccc85da7382d00294fdaf SHA512 7434365766f5ba893b5b51e852d73af6b1dd562f3804e46b2aa5bf2097694d5465f0ddb5e401b157ed899a86caca2dd405424c5a7c86d66190cefd30eee3ba65
+DIST mat2-0.10.1.tar.gz 5780327 BLAKE2B d8ffeb1c10409aa4fb93849e641c13bb65508441fb847db2a46f289becd33a160ac711c3c3fb302bfbacd5704acc9b15876a182916cf3d34bf8bb867836fe6b4 SHA512 ee6ec621b3e98cfcf2f341364f60d853be8aedbee88fd41d2cc97888ba7ee33f7610f165cdf140e0169fbdabd41ecafe80a30dab44dc9f2b1cb501973a8e403a
diff --git a/app-misc/mat2/mat2-0.10.0.ebuild b/app-misc/mat2/mat2-0.10.1.ebuild
index a6d6c23e29..96710588b4 100644
--- a/app-misc/mat2/mat2-0.10.0.ebuild
+++ b/app-misc/mat2/mat2-0.10.1.ebuild
@@ -1,27 +1,27 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-# Supports python3_8 but not all it's deps in the tree do yet
-PYTHON_COMPAT=(python3_{5,6,7})
+PYTHON_COMPAT=(python3_{6,7,8})
PYTHON_REQ_USE="xml"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
inherit distutils-r1
DESCRIPTION="Metadata Anonymisation Toolkit: handy tool to trash your metadata"
HOMEPAGE="https://0xacab.org/jvoisin/mat2"
+SRC_URI="https://0xacab.org/jvoisin/mat2/-/archive/${PV}/${P}.tar.gz"
+
LICENSE="LGPL-3"
SLOT="0"
-SRC_URI="https://0xacab.org/jvoisin/mat2/-/archive/${PV}/${P}.tar.gz"
KEYWORDS="~amd64"
-IUSE="+exif sandbox video test"
+
+IUSE="+exif sandbox video"
REQUIRED_USE="${PYTHON_REQUIRED_USE} test? ( exif video )"
-RESTRICT="!test? ( test )"
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="
- ${DEPEND}
+RDEPEND="${PYTHON_DEPS}
media-libs/mutagen:0[${PYTHON_USEDEP}]
dev-python/pycairo:0[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
@@ -31,10 +31,12 @@ RDEPEND="
exif? ( media-libs/exiftool:* )
sandbox? ( sys-apps/bubblewrap )
video? ( media-video/ffmpeg:* )
+"
+
+DEPEND="${RDEPEND}
test? (
media-video/ffmpeg[mp3,vorbis]
x11-libs/gdk-pixbuf:2[jpeg,tiff]
- )
-"
+ )"
distutils_enable_tests unittest