aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-09-19 16:23:47 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-09-19 16:24:23 +0200
commit4e65baa2da89ccdf40b88b0bb72db313cd14f2d2 (patch)
tree026d8d39bf8d973be3a16288e7af18f7faeb02cd /app-misc/ntfy
parentgames-action/ATLauncher: version bump (diff)
downloadguru-4e65baa2da89ccdf40b88b0bb72db313cd14f2d2.tar.gz
guru-4e65baa2da89ccdf40b88b0bb72db313cd14f2d2.tar.bz2
guru-4e65baa2da89ccdf40b88b0bb72db313cd14f2d2.zip
app-misc/ntfy: sleekxmpp removed from ::gentoo
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'app-misc/ntfy')
-rw-r--r--app-misc/ntfy/ntfy-2.7.0.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/app-misc/ntfy/ntfy-2.7.0.ebuild b/app-misc/ntfy/ntfy-2.7.0.ebuild
index 771af3d6d..c789b2761 100644
--- a/app-misc/ntfy/ntfy-2.7.0.ebuild
+++ b/app-misc/ntfy/ntfy-2.7.0.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -37,9 +38,17 @@ DEPEND="${RDEPEND}
dev-python/emoji[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/sleekxmpp[${PYTHON_USEDEP}]
)
"
+python_prepare_all() {
+ # Sleekxmpp no longer in repo
+ rm tests/test_xmpp.py || die
+ sed -i -e 's:test_xmpp:_&:' \
+ tests/test_integration.py || die
+
+ distutils-r1_python_prepare_all
+}
+
distutils_enable_tests pytest
distutils_enable_sphinx docs