aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-04-11 22:37:04 +1200
committerTheo Anderson <telans@posteo.de>2021-04-11 22:38:56 +1200
commit1e3218cc45003fc3e505df28c5cf859910008d9a (patch)
tree6faa6230a7ffac7d6f36de110254676f1c2eb013 /dev-lang
parentmedia-gfx/qview: touch to close #781110 (diff)
downloadguru-1e3218cc45003fc3e505df28c5cf859910008d9a.tar.gz
guru-1e3218cc45003fc3e505df28c5cf859910008d9a.tar.bz2
guru-1e3218cc45003fc3e505df28c5cf859910008d9a.zip
dev-lang/gleam: fix compile
* don't treat warnings as errors * specify QA_FLAGS_IGNORED Closes: https://bugs.gentoo.org/780999 Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gleam/gleam-0.12.1.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/dev-lang/gleam/gleam-0.12.1.ebuild b/dev-lang/gleam/gleam-0.12.1.ebuild
index d6dc4025d..8ed01a968 100644
--- a/dev-lang/gleam/gleam-0.12.1.ebuild
+++ b/dev-lang/gleam/gleam-0.12.1.ebuild
@@ -259,3 +259,15 @@ LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD BSL-1.1 CC0-1.0 MI
SLOT="0"
KEYWORDS="~amd64"
RESTRICT="mirror"
+
+QA_FLAGS_IGNORED="usr/bin/gleam"
+
+src_configure() {
+ export RUSTFLAGS="${RUSTFLAGS} --cap-lints warn"
+ cargo_src_configure
+}
+
+src_install() {
+ cargo_src_install
+ einstalldocs
+}