aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-03 18:21:32 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-03 18:21:32 +0100
commit684d72097650eab195fd0587f5e083fb6d74ef0e (patch)
tree754494ed075cff5b2ce0e56930630b89a0a3dd18 /dev-lang
parentapp-text/noweb: DOCS are already in default DOCS (diff)
downloadguru-684d72097650eab195fd0587f5e083fb6d74ef0e.tar.gz
guru-684d72097650eab195fd0587f5e083fb6d74ef0e.tar.bz2
guru-684d72097650eab195fd0587f5e083fb6d74ef0e.zip
dev-lang/aldor: Fix S variable
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/aldor/aldor-1.2.0_p20190730.ebuild30
1 files changed, 19 insertions, 11 deletions
diff --git a/dev-lang/aldor/aldor-1.2.0_p20190730.ebuild b/dev-lang/aldor/aldor-1.2.0_p20190730.ebuild
index 952e5919a..bb79cb1f4 100644
--- a/dev-lang/aldor/aldor-1.2.0_p20190730.ebuild
+++ b/dev-lang/aldor/aldor-1.2.0_p20190730.ebuild
@@ -6,17 +6,21 @@ EAPI="7"
COMMIT="13e5b90eecc79ec6704efb333c4c100187520e80"
AUTOTOOLS_AUTORECONF=1
AUTOTOOLS_IN_SOURCE_BUILD=1
+
inherit autotools elisp-common
DESCRIPTION="The Aldor Programming Language"
HOMEPAGE="http://pippijn.github.io/aldor"
-SRC_URI=" https://github.com/pippijn/aldor/archive/${COMMIT}.tar.gz -> ${P}.tar.gz
- doc? ( http://aldor.org/docs/libaldor.pdf.gz )
- emacs? ( http://hemmecke.de/aldor/aldor.el.nw )"
+SRC_URI="
+ https://github.com/pippijn/aldor/archive/${COMMIT}.tar.gz -> ${P}.tar.gz
+ doc? ( http://aldor.org/docs/libaldor.pdf.gz )
+ emacs? ( http://hemmecke.de/aldor/aldor.el.nw )
+"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
+
IUSE="doc emacs"
RDEPEND="
@@ -30,9 +34,15 @@ DEPEND="
emacs? ( app-text/noweb )
"
-DOCS=( AUTHORS COPYRIGHT LICENSE )
+S="${WORKDIR}/${PN}-${COMMIT}/aldor"
-S="${WORKDIR}/${P}/aldor"
+DOCS=( AUTHORS README.building README.binary-only README.library ../README.md )
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ use doc && cp "${DISTDIR}/libaldor.pdf.gz" "${S}" && gunzip "${S}/libaldor.pdf.gz" || die
+ use emacs && cp "${DISTDIR}/aldor.el.nw" "${S}" || die
+}
src_compile() {
if use doc ; then
@@ -40,20 +50,18 @@ src_compile() {
( cd lib/aldor/tutorial
pdflatex tutorial.tex
pdflatex tutorial.tex ) || die "make tutorial.pdf failed"
- cp "${DISTDIR}/libaldor.pdf.gz" .
- gunzip libaldor.pdf.gz
tar xzf "${DISTDIR}/algebra.html.tar.gz"
fi
if use emacs ; then
- notangle "${DISTDIR}/aldor.el.nw" > aldor.el
- notangle -Rinit.el "${DISTDIR}/aldor.el.nw" | \
+ notangle "aldor.el.nw" > aldor.el
+ notangle -Rinit.el "aldor.el.nw" | \
sed -e '1s/^.*$/;; aldor mode/' > 64aldor-gentoo.el
if use doc ; then
einfo "Documentation for the aldor emacs mode"
- noweave "${DISTDIR}/aldor.el.nw" > aldor-mode.tex
- pdflatex aldor-mode.tex
+ noweave "aldor.el.nw" > aldor-mode.tex
pdflatex aldor-mode.tex
+ pdflatex aldor-mode.tex || die "make aldor-mode.pdf failed"
fi
fi
default