aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-24 19:47:19 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-24 19:47:19 +0100
commit8c501e2d1240b9abe48df652da643e95b1d3e9cc (patch)
tree1b4f18b5f4840364b9e4ddf3de0b62ad006660fa /dev-python/httpcore
parentdev-vcs/lazygit: drop old 0.20.9, 0.22.9 (diff)
downloadguru-8c501e2d1240b9abe48df652da643e95b1d3e9cc.tar.gz
guru-8c501e2d1240b9abe48df652da643e95b1d3e9cc.tar.bz2
guru-8c501e2d1240b9abe48df652da643e95b1d3e9cc.zip
dev-python/{gssapi,httpcore,httpx,uvicorn}: moved to ::gentoo
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest2
-rw-r--r--dev-python/httpcore/httpcore-0.10.1.ebuild44
-rw-r--r--dev-python/httpcore/httpcore-0.12.3.ebuild48
-rw-r--r--dev-python/httpcore/metadata.xml26
4 files changed, 0 insertions, 120 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
deleted file mode 100644
index b4f192135..000000000
--- a/dev-python/httpcore/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST httpcore-0.10.1.tar.gz 42164 BLAKE2B 939dac21235f56e0d39ee4cbe7dca9f686fb086598c35d5335532baaa4fb36e904f9cb9676ba8c412deb5f560a1b379d599993148fda11e74a18a37743613ee5 SHA512 1eddc62f0b2a0c48166de0d2f1717de7db2dd1e1ae959d07ed74e19e098fb5470c4a94348d33614226671870edf134288808aea332abb71f776bb733ff26053f
-DIST httpcore-0.12.3.tar.gz 57587 BLAKE2B 3c0e7a210b21e54564c4c6077fadf66344b887662c71b05a1ad4a2c0224a4d703eccdf576d4443341176edee03b6776bfd49aaef2ea2f29f02614677e1dfad85 SHA512 b31535231dc2b6a5f1c9c0c538628f75360f04b4747b447ab0a7168ed32d0eabd463335c2f7fa782dcabb4cbc32891a2839ae50e0999d5a791c01b02533d38f0
diff --git a/dev-python/httpcore/httpcore-0.10.1.ebuild b/dev-python/httpcore/httpcore-0.10.1.ebuild
deleted file mode 100644
index 5df6a34ee..000000000
--- a/dev-python/httpcore/httpcore-0.10.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-DOCS_BUILDER="mkdocs"
-DOCS_DEPEND="dev-python/mkdocs-material"
-DOCS_AUTODOC=1
-
-inherit distutils-r1 docs
-
-DESCRIPTION="A minimal HTTP client"
-HOMEPAGE="
- https://github.com/encode/httpcore
- https://pypi.org/project/httpcore
-"
-SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# Temporary failure in name resolution
-# requires masked mitmproxy
-RESTRICT="test"
-
-RDEPEND="
- dev-python/h11[${PYTHON_USEDEP}]
- dev-python/hyper-h2[${PYTHON_USEDEP}]
- dev-python/sniffio[${PYTHON_USEDEP}]
- dev-python/trio[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- ${RDEPEND}
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-trio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
diff --git a/dev-python/httpcore/httpcore-0.12.3.ebuild b/dev-python/httpcore/httpcore-0.12.3.ebuild
deleted file mode 100644
index ee00ef4e3..000000000
--- a/dev-python/httpcore/httpcore-0.12.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-DOCS_BUILDER="mkdocs"
-DOCS_DEPEND="dev-python/mkdocs-material"
-DOCS_AUTODOC=1
-
-inherit distutils-r1 docs
-
-DESCRIPTION="A minimal HTTP client"
-HOMEPAGE="
- https://github.com/encode/httpcore
- https://pypi.org/project/httpcore
-"
-SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# httpcore.ConnectError: [Errno 16] Device or resource busy
-RESTRICT="test"
-
-RDEPEND="
- >=dev-python/curio-1.4[${PYTHON_USEDEP}]
- <dev-python/h11-1[${PYTHON_USEDEP}]
- >=dev-python/hyper-h2-3[${PYTHON_USEDEP}]
- <dev-python/hyper-h2-5[${PYTHON_USEDEP}]
- >=dev-python/sniffio-1[${PYTHON_USEDEP}]
- <dev-python/sniffio-2[${PYTHON_USEDEP}]
- >=dev-python/trio-0.17.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- test? (
- >=dev-python/anyio-2.0.2[${PYTHON_USEDEP}]
- >=dev-python/hypercorn-0.11.1[${PYTHON_USEDEP}]
- >=dev-python/pproxy-2.3.7[${PYTHON_USEDEP}]
- >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/trustme-0.6.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
diff --git a/dev-python/httpcore/metadata.xml b/dev-python/httpcore/metadata.xml
deleted file mode 100644
index 8b1dc8362..000000000
--- a/dev-python/httpcore/metadata.xml
+++ /dev/null
@@ -1,26 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>lssndrbarbieri@gmail.com</email>
- <name>Alessandro Barbieri</name>
- </maintainer>
- <longdescription lang="en">
-The HTTP Core package provides a minimal low-level HTTP client, which does one thing only. Sending HTTP requests.
-
-It does not provide any high level model abstractions over the API, does not handle redirects, multipart uploads, building authentication headers, transparent HTTP caching, URL parsing, session cookie handling, content or charset decoding, handling JSON, environment based configuration defaults, or any of that Jazz.
-
-Some things HTTP Core does do:
-
- Sending HTTP requests.
- Provides both sync and async interfaces.
- Supports HTTP/1.1 and HTTP/2.
- Async backend support for asyncio and trio.
- Automatic connection pooling.
- HTTP(S) proxy support.
- </longdescription>
- <upstream>
- <remote-id type="github">https://github.com/encode/httpcore</remote-id>
- <remote-id type="pypi">httpcore</remote-id>
- </upstream>
-</pkgmetadata>