aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-30 17:50:41 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-30 17:53:17 +0200
commit5e71fb95fafea6a27bc5e715ba211edeee87cf2c (patch)
tree730e722639ed761b5018385077a1c538a676a0a4 /dev-python/sanic
parentdev-python/sanic: drop websockets restriction (diff)
downloadguru-5e71fb95fafea6a27bc5e715ba211edeee87cf2c.tar.gz
guru-5e71fb95fafea6a27bc5e715ba211edeee87cf2c.tar.bz2
guru-5e71fb95fafea6a27bc5e715ba211edeee87cf2c.zip
dev-python/sanic: drop old
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/sanic')
-rw-r--r--dev-python/sanic/Manifest1
-rw-r--r--dev-python/sanic/sanic-20.9.1.ebuild64
2 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/sanic/Manifest b/dev-python/sanic/Manifest
index ee74883b9..a7ceefe58 100644
--- a/dev-python/sanic/Manifest
+++ b/dev-python/sanic/Manifest
@@ -1,2 +1 @@
-DIST sanic-20.9.1.tar.gz 214560 BLAKE2B 2df6127d9a4b0cc8fc60e2aafe47b4e10f1474b3bee5b3974265be8c5edcfd2f7fdccb4d2b3f977d2f51ff0a2d0dc33c2d120c7d858fae56d845f6b22261eb7e SHA512 4c19fa2731b98eeb843c272856a2e6a4d25817b29d490dfa9c7e4f086ca91b5a8f4c38488673029ca21d125858d6095f40a960284c487b2601bef2c1fdedca28
DIST sanic-21.3.4.tar.gz 234229 BLAKE2B a24941777099d5a09dd020a7f0a9fe39ae0ab89436fe27e2e4bbb418b684583002b9249e46438787d07bae6114ee1a0fd27e24e4e29983e8499f766f238e07d9 SHA512 15596f37b5389073d6a2b5e2d2bf5871d9a31ba29bf4e2eac9fb91df29e76035b02f7d892bb8edd5ffde75f05acdcebdb2c8f5ddf7224f40c5391c8f058f5c97
diff --git a/dev-python/sanic/sanic-20.9.1.ebuild b/dev-python/sanic/sanic-20.9.1.ebuild
deleted file mode 100644
index 8f522d970..000000000
--- a/dev-python/sanic/sanic-20.9.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Async Python 3.6+ web server/framework | Build fast. Run fast."
-HOMEPAGE="
- https://pypi.python.org/pypi/sanic
- https://github.com/huge-success/sanic
-"
-SRC_URI="https://github.com/huge-success/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# lots of these
-# ValueError: Exception during request: [AttributeError("'AsyncConnectionPool' object has no attribute 'arequest'")]
-RESTRICT="test"
-
-RDEPEND="
- dev-python/aiofiles[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- >=dev-python/httptools-0.0.10[${PYTHON_USEDEP}]
- dev-python/multidict[${PYTHON_USEDEP}]
- dev-python/ujson[${PYTHON_USEDEP}]
- dev-python/uvloop[${PYTHON_USEDEP}]
- >=dev-python/websockets-8.1[${PYTHON_USEDEP}]
- <dev-python/websockets-9.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- test? (
- dev-python/beautifulsoup[${PYTHON_USEDEP}]
- >=dev-python/httpcore-0.3.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-5.2.1[${PYTHON_USEDEP}]
- dev-python/pytest-benchmark[${PYTHON_USEDEP}]
- dev-python/pytest-sanic[${PYTHON_USEDEP}]
- dev-python/uvicorn[${PYTHON_USEDEP}]
- www-servers/gunicorn[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/docutils \
- dev-python/pygments \
- dev-python/sphinx_rtd_theme \
- dev-python/recommonmark \
- www-servers/gunicorn
-
-python_prepare_all() {
- # 'dependency' not found in `markers` configuration option
- # requires pytest version which is no longer in ::gentoo
- rm tests/test_load_module_from_file_location.py || die
- rm tests/test_update_config.py || die
-
- distutils-r1_python_prepare_all
-}