aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-05-27 16:47:31 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-05-27 16:48:17 +0200
commit9fa3f60c38d0f215bf148b9be2d84348cd4b2afb (patch)
treedcac8dba2a4cf88cd051a8c47cca9edece312c4e /dev-python/sanic
parentdev-python/sanic-testing: initial import (diff)
downloadguru-9fa3f60c38d0f215bf148b9be2d84348cd4b2afb.tar.gz
guru-9fa3f60c38d0f215bf148b9be2d84348cd4b2afb.tar.bz2
guru-9fa3f60c38d0f215bf148b9be2d84348cd4b2afb.zip
dev-python/sanic: add 21.3.4
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/sanic')
-rw-r--r--dev-python/sanic/Manifest1
-rw-r--r--dev-python/sanic/sanic-21.3.4.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/sanic/Manifest b/dev-python/sanic/Manifest
index c240b52dd5..ee74883b93 100644
--- a/dev-python/sanic/Manifest
+++ b/dev-python/sanic/Manifest
@@ -1 +1,2 @@
DIST sanic-20.9.1.tar.gz 214560 BLAKE2B 2df6127d9a4b0cc8fc60e2aafe47b4e10f1474b3bee5b3974265be8c5edcfd2f7fdccb4d2b3f977d2f51ff0a2d0dc33c2d120c7d858fae56d845f6b22261eb7e SHA512 4c19fa2731b98eeb843c272856a2e6a4d25817b29d490dfa9c7e4f086ca91b5a8f4c38488673029ca21d125858d6095f40a960284c487b2601bef2c1fdedca28
+DIST sanic-21.3.4.tar.gz 234229 BLAKE2B a24941777099d5a09dd020a7f0a9fe39ae0ab89436fe27e2e4bbb418b684583002b9249e46438787d07bae6114ee1a0fd27e24e4e29983e8499f766f238e07d9 SHA512 15596f37b5389073d6a2b5e2d2bf5871d9a31ba29bf4e2eac9fb91df29e76035b02f7d892bb8edd5ffde75f05acdcebdb2c8f5ddf7224f40c5391c8f058f5c97
diff --git a/dev-python/sanic/sanic-21.3.4.ebuild b/dev-python/sanic/sanic-21.3.4.ebuild
new file mode 100644
index 0000000000..bc79bf25f0
--- /dev/null
+++ b/dev-python/sanic/sanic-21.3.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Async Python 3.6+ web server/framework | Build fast. Run fast."
+HOMEPAGE="
+ https://pypi.python.org/pypi/sanic
+ https://github.com/huge-success/sanic
+"
+SRC_URI="https://github.com/huge-success/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/aiofiles-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/httptools-0.0.10[${PYTHON_USEDEP}]
+ >=dev-python/multidict-5.0[${PYTHON_USEDEP}]
+ <dev-python/multidict-6.0[${PYTHON_USEDEP}]
+ >=dev-python/sanic-routing-0.0.10[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}]
+ >=dev-python/websockets-8.1[${PYTHON_USEDEP}]
+ <dev-python/websockets-9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ >=dev-python/httpcore-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.2.1[${PYTHON_USEDEP}]
+ dev-python/pytest-benchmark[${PYTHON_USEDEP}]
+ dev-python/pytest-sanic[${PYTHON_USEDEP}]
+ dev-python/sanic-testing[${PYTHON_USEDEP}]
+ dev-python/uvicorn[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/docutils \
+ dev-python/pygments \
+ dev-python/sphinx_rtd_theme \
+ dev-python/recommonmark \
+ www-servers/gunicorn
+
+python_test() {
+ pytest -vv --deselect tests/test_unix_socket.py::test_zero_downtime || die
+}