aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-02-10 15:08:24 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-02-10 15:11:06 +0100
commit744f03002c637d9ad4fd63c3051350d84dd91c37 (patch)
tree67b11f688901959895d9ad88aaf890b3c7e4745b /dev-python
parentdev-python/timeout-decorator: Fix metadata (diff)
downloadguru-744f03002c637d9ad4fd63c3051350d84dd91c37.tar.gz
guru-744f03002c637d9ad4fd63c3051350d84dd91c37.tar.bz2
guru-744f03002c637d9ad4fd63c3051350d84dd91c37.zip
dev-python/tekore: Fix IUSE="doc"
distutils_enable_sphinx acts weird when there is only one python version in PYTHON_COMPAT, for some reason it wants to add PYTHON_SINGLE_TARGET to use of sphinx-* deps, but these deps don't have PYTHON_SINGLE_TARGET Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tekore/tekore-1.1.0.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-python/tekore/tekore-1.1.0.ebuild b/dev-python/tekore/tekore-1.1.0.ebuild
index f356ed9f8..456c7d2eb 100644
--- a/dev-python/tekore/tekore-1.1.0.ebuild
+++ b/dev-python/tekore/tekore-1.1.0.ebuild
@@ -16,12 +16,23 @@ LICENSE="MIT"
KEYWORDS="~amd64 ~x86"
SLOT="0"
+distutils_enable_sphinx docs
+
+# the enable_sphinx fucntion seems to act strange when there is only 1 PYTHON_COMPAT
+# repoman says:
+# dev-python/tekore/tekore-1.1.0.ebuild: BDEPEND: ~x86(default/linux/x86/17.0/systemd)
+# [ 'dev-python/sphinx[python_targets_python3_7(-),python_single_target_python3_7(+)]']
+# therefore we overwrite the deps that the function adds here:
+BDEPEND="doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx-autodoc-typehints[${PYTHON_USEDEP}] )"
+
RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
dev-python/httpx[${PYTHON_USEDEP}]"
DOCS="readme.rst"
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] dev-python/sphinx-autodoc-typehints[${PYTHON_USEDEP}]
distutils_enable_tests pytest
python_prepare_all() {