aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-15 19:27:59 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-16 01:28:25 +0200
commit7ec436045b801145a7f26fffb702f0c5007e3dfc (patch)
tree6b993ee04492ec6859148508c3ffc81f17d5a277 /dev-python
parentdev-python/pytest-celery: add 0.0.0, drop 0.0.0_alpha1 (diff)
downloadguru-7ec436045b801145a7f26fffb702f0c5007e3dfc.tar.gz
guru-7ec436045b801145a7f26fffb702f0c5007e3dfc.tar.bz2
guru-7ec436045b801145a7f26fffb702f0c5007e3dfc.zip
dev-python/celery: add 5.1.0, drop 5.1.0_beta2
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/celery/Manifest2
-rw-r--r--dev-python/celery/celery-5.1.0.ebuild (renamed from dev-python/celery/celery-5.1.0_beta2.ebuild)13
2 files changed, 8 insertions, 7 deletions
diff --git a/dev-python/celery/Manifest b/dev-python/celery/Manifest
index 7443b7b5d..601e883ba 100644
--- a/dev-python/celery/Manifest
+++ b/dev-python/celery/Manifest
@@ -1 +1 @@
-DIST celery-5.1.0_beta2.tar.gz 1459863 BLAKE2B 1b5a49728fa97e00112cc31731998ac06b2bb77ed621321b119d44d8cf0e4ec347d92b0857f316bda48f61a0ce0bd5c9d55392a8e3053369577d503af7aafc35 SHA512 d430a33cbc34950d68cf228707e8e868834f80a7f6c40491d8a67b056af5395c03e27c2b2ba1e2b9a390598d7d8bb3609bd88b388dfb18a34d0441ed54245192
+DIST celery-5.1.0.tar.gz 1468143 BLAKE2B e066941c6d214bb6bb9afec8100a2fa5e5c96da0f46cb0821d0cbf8aa6607e22320a1f46d48b7aae0f91f4d6c1d9d2143f50b0927a186f8aebc13d3fcc48b6af SHA512 78368767d1acb799d96036a4f0dab03b085c9a393f52f184080be1100a3c55c97b492d37be0944eca2cd55cfa21128c80e19537233702b1ee136027e47f889f8
diff --git a/dev-python/celery/celery-5.1.0_beta2.ebuild b/dev-python/celery/celery-5.1.0.ebuild
index 3f2f4e684..3f2ff0b55 100644
--- a/dev-python/celery/celery-5.1.0_beta2.ebuild
+++ b/dev-python/celery/celery-5.1.0.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7,8} )
+MYPV="${PV/_beta/b}"
+PYTHON_COMPAT=( python3_8 )
inherit bash-completion-r1 distutils-r1 eutils optfeature
-MYPV="${PV/_beta/b}"
DESCRIPTION="Asynchronous task queue/job queue based on distributed message passing"
HOMEPAGE="
http://celeryproject.org
@@ -15,15 +16,14 @@ HOMEPAGE="
https://github.com/celery/celery
"
SRC_URI="https://github.com/celery/celery/archive/v${MYPV}.tar.gz -> ${P}.tar.gz"
-
+S="${WORKDIR}/${PN}-${MYPV}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
# There are a number of other optional 'extras'
IUSE="examples"
#RESTRICT="!test? ( test )"
-RESTRICT="test" #'celery' not found in `markers` configuration option
-S="${WORKDIR}/${PN}-${MYPV}"
+RESTRICT="test" #amqp wants vine.five
RDEPEND="
>=dev-python/billiard-3.6.4.0[${PYTHON_USEDEP}]
@@ -61,6 +61,7 @@ DEPEND="
dev-python/sqlalchemy[${PYTHON_USEDEP}]
)
"
+
# testsuite needs it own source
DISTUTILS_IN_SOURCE_BUILD=1
distutils_enable_tests pytest