aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-06-09 16:50:04 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-06-09 16:50:04 +0200
commit80259d2edbd2c3a3151bba69494619c02757d84f (patch)
tree882f353b05b879e436842c71224b291441ac799a /dev-python
parentdev-python/aiounittest: version bump, add py3_9 (diff)
downloadguru-80259d2edbd2c3a3151bba69494619c02757d84f.tar.gz
guru-80259d2edbd2c3a3151bba69494619c02757d84f.tar.bz2
guru-80259d2edbd2c3a3151bba69494619c02757d84f.zip
dev-python/aiosqlite: version bump
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aiosqlite/Manifest1
-rw-r--r--dev-python/aiosqlite/aiosqlite-0.13.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/aiosqlite/Manifest b/dev-python/aiosqlite/Manifest
index d300dbbc8..78dc6f03c 100644
--- a/dev-python/aiosqlite/Manifest
+++ b/dev-python/aiosqlite/Manifest
@@ -1 +1,2 @@
DIST aiosqlite-0.12.0.tar.gz 10407 BLAKE2B e8a521fee997677b48f054ecbe72445448c5d15a73baa05dd86535596b95fabb13d933726dd356113506961bfda2147bf3defe2b98f3ab97d26140695a2049c1 SHA512 8bf8531299a5dec48617fd0d39aa25a2611595092e3ff2386041a22846b9ecb04a5951803f44b8073513d5a7b2fe7334d6d75193f6b4b00ba5091fa377a0aa2d
+DIST aiosqlite-0.13.0.tar.gz 22869 BLAKE2B d36701d482fd77b0e4c031c9c205a68d738dbc20b0ed65246cda8d1c56587fc33850023a76685e0e27b008997cd47d472c8d8d742c0fb5c19db64f471764cb55 SHA512 f6304803f9533c8caded7e28feabe18367ee436af8a1a138344104708bd46eb7bbf0e0cad347a4e604b821463c4039b0de4ad3e72c6a39cb104d78e7d393fa62
diff --git a/dev-python/aiosqlite/aiosqlite-0.13.0.ebuild b/dev-python/aiosqlite/aiosqlite-0.13.0.ebuild
new file mode 100644
index 000000000..925197a47
--- /dev/null
+++ b/dev-python/aiosqlite/aiosqlite-0.13.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="asyncio bridge to the standard sqlite3 module"
+HOMEPAGE="https://github.com/jreese/aiosqlite"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? (
+ dev-python/aiounittest[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests unittest
+# TypeError: add_source_parser() takes 2 positional arguments but 3 were given
+#distutils_enable_sphinx docs