aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-14 02:20:51 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-14 04:27:30 +0200
commitac74d17dfd56f9ec5364bb9ce2c5e4cb29268c0b (patch)
tree35db300556fa7bec0e1f0ce328121e20abe0fe9e /dev-python
parentdev-python/sphinx-click: add 3.0.0 (diff)
downloadguru-ac74d17dfd56f9ec5364bb9ce2c5e4cb29268c0b.tar.gz
guru-ac74d17dfd56f9ec5364bb9ce2c5e4cb29268c0b.tar.bz2
guru-ac74d17dfd56f9ec5364bb9ce2c5e4cb29268c0b.zip
dev-python/pytest-randomly: add 3.8.0
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-randomly/Manifest1
-rw-r--r--dev-python/pytest-randomly/pytest-randomly-3.8.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pytest-randomly/Manifest b/dev-python/pytest-randomly/Manifest
index f81f4c913..fcc746d43 100644
--- a/dev-python/pytest-randomly/Manifest
+++ b/dev-python/pytest-randomly/Manifest
@@ -1 +1,2 @@
DIST pytest-randomly-3.5.0.tar.gz 36605 BLAKE2B 1e993f7b0cec9fede1fd22c9be06ca34b884ea67183e13197e59359ebb5b8a6bc86715b117f379d72c11eec85fe31c3f4cb1dd7c2bae1412dabd630ddff81bbf SHA512 ed5cc11799e38caaa899ab25f75469baa2c57a5113c3e51129c4cee801b0eded57f6165113f8cb5a8c995057569c224b9039d601b361b9e95553dc8cb338b368
+DIST pytest-randomly-3.8.0.tar.gz 26376 BLAKE2B b51fb09e887fb20783edaecc6494d22c9e66c4c87aabe5368f85b492681c29c9283ddc70821801442d4908a76ba64e70ee04433f5bd3639bae0cf198c950dcb1 SHA512 eabed09478f3047f181b4efe1057d15dda5686f85d3321083fbd443e5dd036f9fc9bfca2048ff898a194d59349e46ebf6258f03caccf649e891bb0bc6d6ef863
diff --git a/dev-python/pytest-randomly/pytest-randomly-3.8.0.ebuild b/dev-python/pytest-randomly/pytest-randomly-3.8.0.ebuild
new file mode 100644
index 000000000..fe9d7905c
--- /dev/null
+++ b/dev-python/pytest-randomly/pytest-randomly-3.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin to randomly order tests and control random.seed"
+HOMEPAGE="
+ https://pypi.python.org/pypi/pytest-randomly
+ https://github.com/pytest-dev/pytest-randomly
+"
+SRC_URI="https://github.com/pytest-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/factory_boy[${PYTHON_USEDEP}]
+ dev-python/Faker[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+
+ $(python_gen_cond_dep 'dev-python/pygments[${PYTHON_USEDEP}]' python3_9)
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing --via-root
+ pytest -vv || die "Testsuite failed under ${EPYTHON}"
+}