aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-07-05 13:50:26 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-07-05 13:50:51 +0200
commitf321f8406f4e26a141924b9c74e30e12b2fb0ce9 (patch)
tree4b475882b31bb0970c6a51815e67a0c6ddeac436 /dev-python
parentsys-apps/flatpak: bump to 1.8.1 (diff)
downloadguru-f321f8406f4e26a141924b9c74e30e12b2fb0ce9.tar.gz
guru-f321f8406f4e26a141924b9c74e30e12b2fb0ce9.tar.bz2
guru-f321f8406f4e26a141924b9c74e30e12b2fb0ce9.zip
dev-python/starlette: minor changes
tried to get tests working now that we have newer graphql but didn't work :( Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/starlette/starlette-0.13.4.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-python/starlette/starlette-0.13.4.ebuild b/dev-python/starlette/starlette-0.13.4.ebuild
index 84b0d96a..d337b975 100644
--- a/dev-python/starlette/starlette-0.13.4.ebuild
+++ b/dev-python/starlette/starlette-0.13.4.ebuild
@@ -22,13 +22,13 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-# ModuleNotFoundError: No module named 'graphql.pyutils.compat'
-# We need newer graphql-core
+# ModuleNotFoundError: No module named 'graphql.execution.executors'
+# Now graphql is at the newest version and this still doesn't work :(
+# though there are less errors now
RESTRICT="test"
DEPEND="test? (
+ dev-python/aiosqlite[${PYTHON_USEDEP}]
dev-python/aiofiles[${PYTHON_USEDEP}]
dev-python/black[${PYTHON_USEDEP}]
dev-python/databases[${PYTHON_USEDEP}]
@@ -40,7 +40,8 @@ DEPEND="test? (
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/sse-starlette[${PYTHON_USEDEP}]
dev-python/ujson[${PYTHON_USEDEP}]
- dev-python/graphene[${PYTHON_USEDEP}] )"
+ dev-python/graphene[${PYTHON_USEDEP}]
+)"
python_prepare_all() {
# do not install LICENSE to /usr/