aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2020-09-20 20:50:29 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2020-09-20 20:56:47 +0300
commitf0a0eef13a666e4a7ca07d2c9958944ed058fde4 (patch)
tree18b2413e545a424c6fae35bfeb083a0e11e04718 /dev-vcs
parentgames-engines/luxtorpeda: new package (diff)
downloadguru-f0a0eef13a666e4a7ca07d2c9958944ed058fde4.tar.gz
guru-f0a0eef13a666e4a7ca07d2c9958944ed058fde4.tar.bz2
guru-f0a0eef13a666e4a7ca07d2c9958944ed058fde4.zip
dev-vcs/lazygit: 0.22.9 version bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/lazygit/Manifest1
-rw-r--r--dev-vcs/lazygit/lazygit-0.22.9.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-vcs/lazygit/Manifest b/dev-vcs/lazygit/Manifest
index 8d0509727..0fd19d805 100644
--- a/dev-vcs/lazygit/Manifest
+++ b/dev-vcs/lazygit/Manifest
@@ -1,3 +1,4 @@
DIST lazygit-0.20.8.tar.gz 9196124 BLAKE2B 5b15ab738b05ffd43d87f2f8858eaab7f4e489b4c5d5de68a0635026083b1b73cbd725d40d6074d3b98321648b28f1e7747389bb620c92cfa2fd3cd97861affa SHA512 22abed21ccb7882d6cde6928f7fa5e3ac203d353a1d85a38d9be0971c927b59d3bc923e3c168452d7799ee9ec7a567cc2d14824fd5df880d5b3667ef6934e800
DIST lazygit-0.20.9.tar.gz 9196030 BLAKE2B 7fd64d06b3036926b00cc64f684d48a3791561e9b48f4bfbc2134e019caf4c96f8a37e2a1d33c79cab9a840b20f212f999f81d1e5a9763e2902332c298ede613 SHA512 d38fd390076a24b914309b6ecb506fc7b21e48c0bfab14aee5ff3bb7bcb591f47bf82051e5442ca4d4d2a0d864eb1554a64c594aefb130ec4f07861128d124dd
DIST lazygit-0.22.1.tar.gz 9231683 BLAKE2B 0f28add953d2ab01daca3cedc982ac7078b8c8d737fc9877a1b00df30592c822731b89779599b2e76d7b381c17f619f27d5c948077b946ae472e8fa42a0da771 SHA512 1deceaad869d01c73fe7f9bf06d669a370ea44357eeb71c098e539cf6c520ea327bc8cd8a5f7e1c66d4e2aab72c80122814a1468e60bdc082b4d4c464e9f915f
+DIST lazygit-0.22.9.tar.gz 9232631 BLAKE2B 50febf0727dc3fff0e61b158bc37df4128cdc9934a42b113612896a3712fb7cd0ce0a0860eec88cbbde289fd08fb492e851937be549a2036ad993bdeb3a101ae SHA512 9d4dc92762099c141e56bbb386217ea2028ba6a78d6bb5d54ef9c022e447a1b9fa2ce37d6e2813411fe6fa4f5192753beec8b136838aefe067019fd0820225e1
diff --git a/dev-vcs/lazygit/lazygit-0.22.9.ebuild b/dev-vcs/lazygit/lazygit-0.22.9.ebuild
new file mode 100644
index 000000000..df46884b8
--- /dev/null
+++ b/dev-vcs/lazygit/lazygit-0.22.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/jesseduffield/lazygit"
+
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Lazygit, a simple terminal UI for git commands"
+HOMEPAGE="https://github.com/jesseduffield/lazygit"
+SRC_URI="https://github.com/jesseduffield/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND=( sys-libs/glibc )
+RDEPEND=(
+ ${DEPEND}
+ dev-vcs/git
+)
+
+DOCS=( src/${EGO_PN}/{CONTRIBUTING,README}.md )
+
+src_compile() {
+ GOPATH="${S}" go build -v -o bin/lazygit src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/lazygit
+
+ use doc && dodoc -r "src/${EGO_PN}/docs/."
+ einstalldocs
+}