aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2020-06-02 12:32:01 +0200
committerOliver Freyermuth <o.freyermuth@googlemail.com>2020-06-02 12:32:01 +0200
commit61fb218f29c5fa928c7e4912e29c803c959d3b62 (patch)
tree23352643f385422cfbd74c45fd13cb5cc9673589 /games-action
parentgames-util/legendary: Delete old ebuilds. (diff)
downloadguru-61fb218f29c5fa928c7e4912e29c803c959d3b62.tar.gz
guru-61fb218f29c5fa928c7e4912e29c803c959d3b62.tar.bz2
guru-61fb218f29c5fa928c7e4912e29c803c959d3b62.zip
games-action/taisei: New package.
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/taisei/Manifest1
-rw-r--r--games-action/taisei/metadata.xml14
-rw-r--r--games-action/taisei/taisei-1.3.1.ebuild57
-rw-r--r--games-action/taisei/taisei-9999.ebuild57
4 files changed, 129 insertions, 0 deletions
diff --git a/games-action/taisei/Manifest b/games-action/taisei/Manifest
new file mode 100644
index 000000000..f1112cb62
--- /dev/null
+++ b/games-action/taisei/Manifest
@@ -0,0 +1 @@
+DIST taisei-v1.3.1.tar.xz 70763196 BLAKE2B ca1901ba0205f6771c087ee70222ceaa3c406a1c632a5f46df1fe4fe493c89af8b587e397551777cd956ab73b5104450356303d0ea0cb8d5cd1b6723ceb1d648 SHA512 5e6f364e67717091041a30103bf117bb5d7a6be76d3d9499b13e36fc190be8c2a0e7ceb582e1d106aa0c1acbb6e39b99a4873a0885af1ec2117ff6ff08e14e3c
diff --git a/games-action/taisei/metadata.xml b/games-action/taisei/metadata.xml
new file mode 100644
index 000000000..b3e78d854
--- /dev/null
+++ b/games-action/taisei/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>o.freyermuth@googlemail.com</email>
+ <name>Oliver Freyermuth</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">taisei-project/taisei</remote-id>
+ </upstream>
+ <use>
+ <flag name="lto">Enable link time optimization</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-action/taisei/taisei-1.3.1.ebuild b/games-action/taisei/taisei-1.3.1.ebuild
new file mode 100644
index 000000000..27ed83838
--- /dev/null
+++ b/games-action/taisei/taisei-1.3.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/taisei-project/taisei.git"
+else
+ SRC_URI="https://github.com/taisei-project/${PN}/releases/download/v${PV}/${PN}-v${PV}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+inherit meson
+
+DESCRIPTION="A free and open-source Touhou Project clone and fangame"
+HOMEPAGE="https://taisei-project.org/"
+
+LICENSE="MIT CC-BY-4.0 CC0-1.0 public-domain"
+SLOT="0"
+IUSE="doc +lto"
+
+RDEPEND="
+ >=media-libs/libsdl2-2.0.6
+ >=media-libs/sdl2-mixer-2.0.4
+ media-libs/freetype:2
+ >=media-libs/libpng-1.5
+ >=media-libs/libwebp-0.5
+ >=dev-libs/libzip-1.2
+ media-libs/opusfile
+ dev-libs/openssl
+ media-libs/shaderc
+ dev-util/spirv-tools"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-util/meson-0.49
+ >=dev-lang/python-3.5
+ doc? ( dev-python/docutils )"
+
+src_prepare() {
+ if use doc; then
+ # Fixup install path for documentation.
+ sed -i "s/doc_path = join_paths(datadir, 'doc', 'taisei')/doc_path = join_paths(datadir, 'doc', '"${P}"')/" meson.build || die
+ fi
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use doc docs)
+ $(meson_use lto b_lto)
+ # Stips binary by default otherwise.
+ -Dstrip=false
+ )
+ meson_src_configure
+}
diff --git a/games-action/taisei/taisei-9999.ebuild b/games-action/taisei/taisei-9999.ebuild
new file mode 100644
index 000000000..27ed83838
--- /dev/null
+++ b/games-action/taisei/taisei-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/taisei-project/taisei.git"
+else
+ SRC_URI="https://github.com/taisei-project/${PN}/releases/download/v${PV}/${PN}-v${PV}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+inherit meson
+
+DESCRIPTION="A free and open-source Touhou Project clone and fangame"
+HOMEPAGE="https://taisei-project.org/"
+
+LICENSE="MIT CC-BY-4.0 CC0-1.0 public-domain"
+SLOT="0"
+IUSE="doc +lto"
+
+RDEPEND="
+ >=media-libs/libsdl2-2.0.6
+ >=media-libs/sdl2-mixer-2.0.4
+ media-libs/freetype:2
+ >=media-libs/libpng-1.5
+ >=media-libs/libwebp-0.5
+ >=dev-libs/libzip-1.2
+ media-libs/opusfile
+ dev-libs/openssl
+ media-libs/shaderc
+ dev-util/spirv-tools"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-util/meson-0.49
+ >=dev-lang/python-3.5
+ doc? ( dev-python/docutils )"
+
+src_prepare() {
+ if use doc; then
+ # Fixup install path for documentation.
+ sed -i "s/doc_path = join_paths(datadir, 'doc', 'taisei')/doc_path = join_paths(datadir, 'doc', '"${P}"')/" meson.build || die
+ fi
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use doc docs)
+ $(meson_use lto b_lto)
+ # Stips binary by default otherwise.
+ -Dstrip=false
+ )
+ meson_src_configure
+}