aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bauer <samuel.bauer@yahoo.fr>2022-05-18 05:20:32 +0200
committerSamuel Bauer <samuel.bauer@yahoo.fr>2022-05-18 05:20:32 +0200
commitcd0b93ea9adcc7148bdc12202a1d25455fb4f825 (patch)
treed71a7a8639fc4983d5bd0437de57d337201200a1 /games-emulation
parentgames-emulation/mupen64plus-qt: version bump (diff)
downloadguru-cd0b93ea9adcc7148bdc12202a1d25455fb4f825.tar.gz
guru-cd0b93ea9adcc7148bdc12202a1d25455fb4f825.tar.bz2
guru-cd0b93ea9adcc7148bdc12202a1d25455fb4f825.zip
games-emulation/mupen64plus-qt: rework quazip includes
Signed-off-by: Samuel Bauer <samuel.bauer@yahoo.fr>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64plus-qt/mupen64plus-qt-1.15.ebuild7
-rw-r--r--games-emulation/mupen64plus-qt/mupen64plus-qt-9999.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/games-emulation/mupen64plus-qt/mupen64plus-qt-1.15.ebuild b/games-emulation/mupen64plus-qt/mupen64plus-qt-1.15.ebuild
index bb5dbf0c0..baea82b25 100644
--- a/games-emulation/mupen64plus-qt/mupen64plus-qt-1.15.ebuild
+++ b/games-emulation/mupen64plus-qt/mupen64plus-qt-1.15.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2018-2021 Gentoo Authors
+# Copyright 2018-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit desktop qmake-utils
@@ -25,7 +25,7 @@ DEPEND=">=games-emulation/mupen64plus-core-2.5
${RDEPEND}"
src_prepare() {
- sed -i -e '/include.*quazip5/s/quazip5/QuaZip-Qt5-1.1\/quazip/' \
+ sed -i -e '/include.*quazip5/s:quazip5/::' \
src/emulation/emulatorhandler.cpp src/common.cpp || die
sed -i -e 's/lquazip5/lquazip1-qt5/' mupen64plus-qt.pro || die
default
@@ -33,6 +33,7 @@ src_prepare() {
src_configure() {
eqmake5
+ sed -i -e "/INCPATH/s:\$: $(pkg-config --cflags-only-I quazip1-qt5):" Makefile || die
}
src_install() {
diff --git a/games-emulation/mupen64plus-qt/mupen64plus-qt-9999.ebuild b/games-emulation/mupen64plus-qt/mupen64plus-qt-9999.ebuild
index 778646412..f4de6352d 100644
--- a/games-emulation/mupen64plus-qt/mupen64plus-qt-9999.ebuild
+++ b/games-emulation/mupen64plus-qt/mupen64plus-qt-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2018-2021 Gentoo Authors
+# Copyright 2018-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit desktop git-r3 qmake-utils
@@ -25,7 +25,7 @@ DEPEND=">=games-emulation/mupen64plus-core-2.5
${RDEPEND}"
src_prepare() {
- sed -i -e '/include.*quazip5/s/quazip5/QuaZip-Qt5-1.1\/quazip/' \
+ sed -i -e '/include.*quazip5/s:quazip5/::' \
src/emulation/emulatorhandler.cpp src/common.cpp || die
sed -i -e 's/lquazip5/lquazip1-qt5/' mupen64plus-qt.pro || die
default
@@ -33,6 +33,7 @@ src_prepare() {
src_configure() {
eqmake5
+ sed -i -e "/INCPATH/s:\$: $(pkg-config --cflags-only-I quazip1-qt5):" Makefile || die
}
src_install() {