aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2020-08-28 19:50:02 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2020-08-28 19:51:13 +0200
commit55b4038b6e71c9840f8eb0a1c6303345a7b916f0 (patch)
treeb5f808267df9e9c0cf3ba9666bf5a8ba77afbdb8 /games-util
parentdev-python/skia-pathops: drop py3.6, add py3.8 (diff)
downloadguru-55b4038b6e71c9840f8eb0a1c6303345a7b916f0.tar.gz
guru-55b4038b6e71c9840f8eb0a1c6303345a7b916f0.tar.bz2
guru-55b4038b6e71c9840f8eb0a1c6303345a7b916f0.zip
games-util/itch-bin: Version bump 25.4.1
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/itch-bin/Manifest1
-rw-r--r--games-util/itch-bin/itch-bin-25.4.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/games-util/itch-bin/Manifest b/games-util/itch-bin/Manifest
index 7a0a6cf61..f32ef703d 100644
--- a/games-util/itch-bin/Manifest
+++ b/games-util/itch-bin/Manifest
@@ -1 +1,2 @@
DIST itch-bin-25.4.0.zip 62941242 BLAKE2B c50f996f98f9ce6e845c44d6c5b176e321f885b7db70569ab5bf526fcc4b21ed1b3428022400457fbdac5c6f387b27865d4768f99c94e60bb18897e68a75a5b2 SHA512 6a0e6fbfba94c162052594ea0442062262690c4ef42889056c42c752cf95b6cabf501c32660c2ba71935a1b1bc0fab946435488385f96c2cd3ab672c9109019d
+DIST itch-bin-25.4.1.zip 81376561 BLAKE2B 9235894252f811338c5ce535a31d52aaa5eeb2a3fc9684841401585e67e94adf135bc137d0b0551861c20039914f38b2f9881238be645ed7b23602229261ee01 SHA512 6c55b2716f64e8206ac6b885e2ec06eddd077dcf4aa9a8ebf17092a6e2c71ea40843cf0396f096264ba7408d559e33ce0e8b98215b299d1a89a749fc3ba7a11a
diff --git a/games-util/itch-bin/itch-bin-25.4.1.ebuild b/games-util/itch-bin/itch-bin-25.4.1.ebuild
new file mode 100644
index 000000000..3efc41264
--- /dev/null
+++ b/games-util/itch-bin/itch-bin-25.4.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg
+
+DESCRIPTION="itch.io game browser, installer and launcher"
+HOMEPAGE="https://itch.io/"
+SRC_URI="https://broth.itch.ovh/itch/linux-amd64/${PV}/archive/default -> ${P}.zip"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="|| ( app-arch/zip app-arch/unzip )"
+RDEPEND="
+ x11-libs/gtk+:3[X,cups]
+ gnome-base/gconf
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/freetype
+ x11-libs/pixman
+ media-libs/libpng:*
+ dev-libs/libpcre
+ net-dns/libidn2
+ net-libs/gnutls
+ dev-libs/libbsd
+ sys-apps/util-linux
+ media-gfx/graphite2
+"
+
+QA_PREBUILT="
+ /opt/itch-bin/itch
+ /opt/itch-bin/libffmpeg.so
+ /opt/itch-bin/libnode.so
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ local destdir="${EPREFIX}/opt/${PN}"
+ insinto "${destdir}"
+ doins -r locales resources
+ doins *.pak *.dat *.bin libffmpeg.so
+
+ exeinto "${destdir}"
+ doexe itch
+ dosym "${destdir}/itch" /usr/bin/itch-bin
+
+ doicon -s 512 "${FILESDIR}/itch-bin.png"
+ make_desktop_entry itch-bin Itch itch-bin Network
+}