aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-04-26 22:47:36 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-04-26 22:47:36 +0200
commit83ff5c44ca8269d4e895ac8d79920a65fe46dcb2 (patch)
tree46a4fcb964ea3e023aa71df1f2e9afb3e0a0ed06 /media-libs
parentnow skia is working (diff)
downloadguru-83ff5c44ca8269d4e895ac8d79920a65fe46dcb2.tar.gz
guru-83ff5c44ca8269d4e895ac8d79920a65fe46dcb2.tar.bz2
guru-83ff5c44ca8269d4e895ac8d79920a65fe46dcb2.zip
media-libs/libavif: removed warning, slotting for rebuilds
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libavif/libavif-0.6.4-r1.ebuild (renamed from media-libs/libavif/libavif-0.6.4.ebuild)24
-rw-r--r--media-libs/libavif/libavif-0.7.2-r1.ebuild (renamed from media-libs/libavif/libavif-0.7.2.ebuild)24
-rw-r--r--media-libs/libavif/libavif-9999.ebuild24
3 files changed, 18 insertions, 54 deletions
diff --git a/media-libs/libavif/libavif-0.6.4.ebuild b/media-libs/libavif/libavif-0.6.4-r1.ebuild
index f30ae5b6f..dd6c75391 100644
--- a/media-libs/libavif/libavif-0.6.4.ebuild
+++ b/media-libs/libavif/libavif-0.6.4-r1.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI="7"
inherit cmake
DESCRIPTION="Library for encoding and decoding .avif files"
HOMEPAGE="https://github.com/AOMediaCodec/libavif"
-if [[ ${PV} == *9999* ]]; then
+if [[ "${PV}" == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/AOMediaCodec/libavif.git"
else
@@ -23,8 +23,8 @@ IUSE="dav1d +libaom rav1e"
REQUIRED_USE="|| ( dav1d libaom )"
DEPEND="dav1d? ( media-libs/dav1d )
- libaom? ( >=media-libs/libaom-1.1 )
- rav1e? ( media-video/rav1e[capi] )
+ libaom? ( >=media-libs/libaom-1.1:= )
+ rav1e? ( media-video/rav1e:=[capi] )
media-libs/libpng
"
RDEPEND="${DEPEND}"
@@ -32,11 +32,11 @@ BDEPEND=""
src_configure() {
local mycmakeargs=(
- -DAVIF_CODEC_DAV1D=$(usex dav1d ON OFF)
+ -DAVIF_BUILD_APPS=ON
-DAVIF_CODEC_AOM=$(usex libaom ON OFF)
+ -DAVIF_CODEC_DAV1D=$(usex dav1d ON OFF)
-DAVIF_CODEC_RAV1E=$(usex rav1e ON OFF)
-DBUILD_SHARED_LIBS=ON
- -DAVIF_BUILD_APPS=ON
)
cmake_src_configure
}
@@ -47,16 +47,4 @@ pkg_postinst() {
ewarn "libavif will work in read-only mode."
ewarn "Enable libaom or rav1e flag if you want to save .AVIF files."
fi
-
- if use libaom ; then
- elog "When you upgrade libaom in the future,"
- elog " you may need to re-emerge libavif again"
- elog " to ensure correct AVIF import/export functions."
- fi
-
- if use rav1e ; then
- elog "When you upgrade rav1e in the future,"
- elog " you may need to re-emerge libavif again"
- elog " to ensure correct AVIF export function."
- fi
}
diff --git a/media-libs/libavif/libavif-0.7.2.ebuild b/media-libs/libavif/libavif-0.7.2-r1.ebuild
index cc370ecb7..15be7ff54 100644
--- a/media-libs/libavif/libavif-0.7.2.ebuild
+++ b/media-libs/libavif/libavif-0.7.2-r1.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI="7"
inherit cmake
DESCRIPTION="Library for encoding and decoding .avif files"
HOMEPAGE="https://github.com/AOMediaCodec/libavif"
-if [[ ${PV} == *9999* ]]; then
+if [[ "${PV}" == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/AOMediaCodec/libavif.git"
else
@@ -23,8 +23,8 @@ IUSE="dav1d +libaom rav1e"
REQUIRED_USE="|| ( dav1d libaom )"
DEPEND="dav1d? ( media-libs/dav1d )
- libaom? ( >=media-libs/libaom-1.1 )
- rav1e? ( media-video/rav1e[capi] )
+ libaom? ( >=media-libs/libaom-1.1:= )
+ rav1e? ( media-video/rav1e:=[capi] )
media-libs/libpng
virtual/jpeg
"
@@ -33,11 +33,11 @@ BDEPEND=""
src_configure() {
local mycmakeargs=(
- -DAVIF_CODEC_DAV1D=$(usex dav1d ON OFF)
+ -DAVIF_BUILD_APPS=ON
-DAVIF_CODEC_AOM=$(usex libaom ON OFF)
+ -DAVIF_CODEC_DAV1D=$(usex dav1d ON OFF)
-DAVIF_CODEC_RAV1E=$(usex rav1e ON OFF)
-DBUILD_SHARED_LIBS=ON
- -DAVIF_BUILD_APPS=ON
)
cmake_src_configure
}
@@ -48,16 +48,4 @@ pkg_postinst() {
ewarn "libavif will work in read-only mode."
ewarn "Enable libaom or rav1e flag if you want to save .AVIF files."
fi
-
- if use libaom ; then
- elog "When you upgrade libaom in the future,"
- elog " you may need to re-emerge libavif again"
- elog " to ensure correct AVIF import/export functions."
- fi
-
- if use rav1e ; then
- elog "When you upgrade rav1e in the future,"
- elog " you may need to re-emerge libavif again"
- elog " to ensure correct AVIF export function."
- fi
}
diff --git a/media-libs/libavif/libavif-9999.ebuild b/media-libs/libavif/libavif-9999.ebuild
index cc370ecb7..15be7ff54 100644
--- a/media-libs/libavif/libavif-9999.ebuild
+++ b/media-libs/libavif/libavif-9999.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI="7"
inherit cmake
DESCRIPTION="Library for encoding and decoding .avif files"
HOMEPAGE="https://github.com/AOMediaCodec/libavif"
-if [[ ${PV} == *9999* ]]; then
+if [[ "${PV}" == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/AOMediaCodec/libavif.git"
else
@@ -23,8 +23,8 @@ IUSE="dav1d +libaom rav1e"
REQUIRED_USE="|| ( dav1d libaom )"
DEPEND="dav1d? ( media-libs/dav1d )
- libaom? ( >=media-libs/libaom-1.1 )
- rav1e? ( media-video/rav1e[capi] )
+ libaom? ( >=media-libs/libaom-1.1:= )
+ rav1e? ( media-video/rav1e:=[capi] )
media-libs/libpng
virtual/jpeg
"
@@ -33,11 +33,11 @@ BDEPEND=""
src_configure() {
local mycmakeargs=(
- -DAVIF_CODEC_DAV1D=$(usex dav1d ON OFF)
+ -DAVIF_BUILD_APPS=ON
-DAVIF_CODEC_AOM=$(usex libaom ON OFF)
+ -DAVIF_CODEC_DAV1D=$(usex dav1d ON OFF)
-DAVIF_CODEC_RAV1E=$(usex rav1e ON OFF)
-DBUILD_SHARED_LIBS=ON
- -DAVIF_BUILD_APPS=ON
)
cmake_src_configure
}
@@ -48,16 +48,4 @@ pkg_postinst() {
ewarn "libavif will work in read-only mode."
ewarn "Enable libaom or rav1e flag if you want to save .AVIF files."
fi
-
- if use libaom ; then
- elog "When you upgrade libaom in the future,"
- elog " you may need to re-emerge libavif again"
- elog " to ensure correct AVIF import/export functions."
- fi
-
- if use rav1e ; then
- elog "When you upgrade rav1e in the future,"
- elog " you may need to re-emerge libavif again"
- elog " to ensure correct AVIF export function."
- fi
}