aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-04-30 15:41:26 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-04-30 15:41:53 +0200
commitbfe7fabcc821ed198e423f557c938e10c0a375fc (patch)
tree7de6a88fdeb0a302446f325e95b021ba3a011021 /media-video
parentmedia-libs/amdvlk: Updated to 2020.Q2.2 (diff)
downloadguru-bfe7fabcc821ed198e423f557c938e10c0a375fc.tar.gz
guru-bfe7fabcc821ed198e423f557c938e10c0a375fc.tar.bz2
guru-bfe7fabcc821ed198e423f557c938e10c0a375fc.zip
media-video/syncplay: Client/server to synchronize media playback
need dev-python/pyside2 for the gui, but should also provide full functionality without the gui Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/syncplay/Manifest1
-rw-r--r--media-video/syncplay/metadata.xml15
-rw-r--r--media-video/syncplay/syncplay-1.6.4_p1.ebuild54
3 files changed, 70 insertions, 0 deletions
diff --git a/media-video/syncplay/Manifest b/media-video/syncplay/Manifest
new file mode 100644
index 000000000..77f72fdeb
--- /dev/null
+++ b/media-video/syncplay/Manifest
@@ -0,0 +1 @@
+DIST syncplay-1.6.4_p1.tar.gz 1791803 BLAKE2B ac309c224ad61c94712f18b3cc7216b9a2fe431251feb2d26b1db3d728bd97b89e6aa362b7b64992152b41a25ac107428f910c24ec0ba88e7c6f042ae1628c07 SHA512 7cf41088462b3140836ba5c2d0376fcae78263255280dfb63575ab8015f21953c78c01d0a2e22c5c09902679cb8ae2f1fdbb5d9fbe4150c5ed8d3d4b8edb49e0
diff --git a/media-video/syncplay/metadata.xml b/media-video/syncplay/metadata.xml
new file mode 100644
index 000000000..0bac473b3
--- /dev/null
+++ b/media-video/syncplay/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <use>
+ <flag name="client">Install the Syncplay client</flag>
+ <flag name="server">Install the Syncplay server</flag>
+ <flag name="vlc">Pull in VLC with the lua flag</flag>
+ <flag name="mpv">Pull in MPV with the lua flag</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-video/syncplay/syncplay-1.6.4_p1.ebuild b/media-video/syncplay/syncplay-1.6.4_p1.ebuild
new file mode 100644
index 000000000..773ee016a
--- /dev/null
+++ b/media-video/syncplay/syncplay-1.6.4_p1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 eutils xdg
+
+MYPV="${PV/_p1/a}"
+
+DESCRIPTION="Client/server to synchronize media playback"
+HOMEPAGE="https://github.com/Syncplay/syncplay https://syncplay.pl"
+SRC_URI="https://github.com/${PN^}/${PN}/archive/v${MYPV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+client +server vlc mpv"
+REQUIRED_USE="vlc? ( client ) mpv? ( client )"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ vlc? ( media-video/vlc[lua] )
+ mpv? ( media-video/mpv[lua] )
+"
+
+# RDEPEND on PySide2 for gui, but not packaged here at the moment
+# It is a too big and complex package for me to maintain
+# You can find PySide2 in the ::raiagent overlay
+
+S="${WORKDIR}/${PN}-${MYPV}"
+
+python_install() {
+ local MY_MAKEOPTS=( DESTDIR="${D}" PREFIX=/usr )
+ use client && \
+ emake "${MY_MAKEOPTS[@]}" install-client
+ use server && \
+ emake "${MY_MAKEOPTS[@]}" install-server
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "using the GUI (you can find it in the raiagent overlay)\n" dev-python/pyside2
+
+ if use client; then
+ elog "Syncplay supports the following players:"
+ elog "media-video/mpv, media-video/mplayer2, media-video/vlc"
+ fi
+}