aboutsummaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2020-05-10 21:57:44 +0500
committerDenis Reva <denis7774@gmail.com>2020-05-10 21:57:44 +0500
commit8c7e43b9572388995d348062048de8e8c0b39bd1 (patch)
treea53bd322b8fcd814f403944b1eb819796b6b66ad /net-fs
parentnet-im/discord-canary: Added (diff)
downloadguru-8c7e43b9572388995d348062048de8e8c0b39bd1.tar.gz
guru-8c7e43b9572388995d348062048de8e8c0b39bd1.tar.bz2
guru-8c7e43b9572388995d348062048de8e8c0b39bd1.zip
net-fs/hubicfuse: n/p FUSE cloud mountpoing for hubiC
A FUSE application which provides access to hubiC's cloud files via a mount-point Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Denis Reva <denis7774@gmail.com>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/hubicfuse/Manifest1
-rw-r--r--net-fs/hubicfuse/hubicfuse-3.0.1.ebuild36
-rw-r--r--net-fs/hubicfuse/metadata.xml51
3 files changed, 88 insertions, 0 deletions
diff --git a/net-fs/hubicfuse/Manifest b/net-fs/hubicfuse/Manifest
new file mode 100644
index 000000000..e2c06451a
--- /dev/null
+++ b/net-fs/hubicfuse/Manifest
@@ -0,0 +1 @@
+DIST hubicfuse-3.0.1.tar.gz 94467 BLAKE2B c30561d9d35378d67666eaf663064bde082775c92e7fd018b57bcebd72939d82892534e62e506be34a2613fb3aa24bd402aa81e6f5e425b0b1922a49bbaf98b4 SHA512 39301395987c8e68c5de57361a6b1ce8c8cd58e3dfdf89b23ff9efd63900eb934261aab6df46d2cf73e4151b9815d1ebe4984cabd9145b83191835e6c4360e16
diff --git a/net-fs/hubicfuse/hubicfuse-3.0.1.ebuild b/net-fs/hubicfuse/hubicfuse-3.0.1.ebuild
new file mode 100644
index 000000000..d1fd3fa86
--- /dev/null
+++ b/net-fs/hubicfuse/hubicfuse-3.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Support for mounting HubiC drive in GNU/Linux"
+HOMEPAGE="https://github.com/TurboGit/hubicfuse"
+SRC_URI="https://github.com/TurboGit/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="libressl"
+
+DEPEND="
+ net-misc/curl
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-fs/fuse:0
+ sys-apps/file
+ dev-libs/libxml2
+ dev-libs/json-c
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md )
+
+src_install() {
+ default
+
+ dobin hubic_token
+
+ ewarn "The hubiC service is now closed to new subscriptions:"
+ ewarn "https://www.ovh.co.uk/subscriptions-hubic-ended/"
+ ewarn "Make sure that you already have hubiC account."
+}
diff --git a/net-fs/hubicfuse/metadata.xml b/net-fs/hubicfuse/metadata.xml
new file mode 100644
index 000000000..b91fcbcfe
--- /dev/null
+++ b/net-fs/hubicfuse/metadata.xml
@@ -0,0 +1,51 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>denis7774@gmail.com</email>
+ <name>Reva Denis aka RarogCmex</name>
+ </maintainer>
+ <longdescription lang="en">
+ A FUSE application which provides access to hubiC's cloud files via a mount-point.
+
+ This version contains support for DLO, symlinks and support to see other tenant's containers.
+ Those features are coming from https://github.com/LabAdvComp/cloudfuse
+ USAGE
+ Your hubiC Cloud configuration can be placed in a file named $HOME/.hubicfuse. All the following variables are required:
+
+ client_id=[hubiC client id for the registered application]
+ client_secret=[hubiC client secret for the registered application]
+ refresh_token=[A refresh token you got from the script]
+ Optional variables:
+
+ get_extended_metadata=[true/false, force download of additional file metadata like atime and mtime on first directory list]
+ curl_verbose=[true/false, enable verbose output for curl HTTP requests]
+ curl_progress_state=[true/false, enable verbose progress output for curl HTTP requests. Used for debugging.]
+ cache_statfs_timeout=[value in seconds, large timeout increases the file access speed]
+ debug_level=[0 default, 1 extremely verbose for debugging purposes]
+ enable_chmod=[true/false, false by default, still experimental feature]
+ enable_chown=[true/false, false by default, still experimental feature]
+ client_id and client_secret can be retrieved from the hubiC web interface
+
+ The refresh_token can be obtained running the script provided (hubic_token) or with any
+ other method you like if you follow the example at https://api.hubic.com/
+
+ Then you can call hubicfuse:
+
+ sudo hubicfuse /mnt/hubic -o noauto_cache,sync_read,allow_other
+ And finaly, it can be set in /etc/fstab:
+
+ hubicfuse /mnt/hubic fuse user,noauto 0 0
+ It also inherits a number of command-line arguments and mount options from the Fuse framework.
+ The "-h" argument should provide a summary.
+
+ It is also possible to pass a custom hubicfuse settings file so that it is possible to mount multiple hubiC accounts:
+
+ sudo hubicfuse /mnt/hubic1 -o noauto_cache,sync_read,allow_other,settings_filename=/root/hubic/account1.settings
+ sudo hubicfuse /mnt/hubic2 -o noauto_cache,sync_read,allow_other,settings_filename=/root/hubic/account2.settings
+ And finaly, in /etc/fstab :
+
+ hubicfuse /mnt/hubic1 fuse user,noauto,settings_filename=/root/hubic/account1.settings 0 0
+ hubicfuse /mnt/hubic2 fuse user,noauto,settings_filename=/root/hubic/account2.settings 0 0
+ </longdescription>
+</pkgmetadata>