aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-02-23 04:51:51 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-02-23 04:51:51 +0100
commitcfe22fac9212b925f4828568e89ecd21f980ec99 (patch)
tree6758a0ae5726d3071772dc56b4ffc0b4ee1ee32d /sys-auth
parentsys-cluster/rankstr: new package (diff)
downloadguru-cfe22fac9212b925f4828568e89ecd21f980ec99.tar.gz
guru-cfe22fac9212b925f4828568e89ecd21f980ec99.tar.bz2
guru-cfe22fac9212b925f4828568e89ecd21f980ec99.zip
sys-auth/mrsh: new package
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/mrsh/Manifest1
-rw-r--r--sys-auth/mrsh/files/union-wait-deprecated.diff20
-rw-r--r--sys-auth/mrsh/metadata.xml18
-rw-r--r--sys-auth/mrsh/mrsh-2.12.ebuild33
4 files changed, 72 insertions, 0 deletions
diff --git a/sys-auth/mrsh/Manifest b/sys-auth/mrsh/Manifest
new file mode 100644
index 000000000..79e107eb3
--- /dev/null
+++ b/sys-auth/mrsh/Manifest
@@ -0,0 +1 @@
+DIST mrsh-2.12.tar.gz 458757 BLAKE2B f7a8a25507eca247814e0cc83730403316d59b1f221fba6bc1abe2f9e86cc083c44dfd886499e60c2ccd13e730204c9d1f0466ad43150bf488950965ce452a63 SHA512 1417197f5c26305287c5f8622800f8f02c5ea0abe1e0c65f9911cda5a3ba466ad75dd8b5120a9c004fbef4086f6627ee805f62801bd0c075e99c8f1298d09135
diff --git a/sys-auth/mrsh/files/union-wait-deprecated.diff b/sys-auth/mrsh/files/union-wait-deprecated.diff
new file mode 100644
index 000000000..bcb6376c1
--- /dev/null
+++ b/sys-auth/mrsh/files/union-wait-deprecated.diff
@@ -0,0 +1,20 @@
+--- a/mrlogin/mrlogin.c 2016-04-29 19:22:08.000000000 +0200
++++ b/mrlogin/mrlogin.c 2019-10-29 02:25:39.095172149 +0100
+@@ -476,7 +476,7 @@
+ void
+ catch_child(int ignore)
+ {
+- union wait status;
++ int status;
+ int pid;
+
+ (void)ignore;
+@@ -487,7 +487,7 @@
+ return;
+ /* if the child (reader) dies, just quit */
+ if (pid < 0 || (pid == childpid && !WIFSTOPPED(status)))
+- done((int)(status.w_termsig | status.w_retcode));
++ done((int)(WTERMSIG(status) | WEXITSTATUS(status)));
+ }
+ /* NOTREACHED */
+ }
diff --git a/sys-auth/mrsh/metadata.xml b/sys-auth/mrsh/metadata.xml
new file mode 100644
index 000000000..68a30cc72
--- /dev/null
+++ b/sys-auth/mrsh/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">chaos/mrsh</remote-id>
+ </upstream>
+<longdescription>Mrsh is a set of remote shell programs that use munge authentication
+rather than reserved ports for security. The code for mrsh is based
+on the source code for rsh, rshd, rlogin, rlogind, and rcp.</longdescription>
+ <use>
+ <flag name="pam">build with pam support</flag>
+ <flag name="shadow">build with shadow file support</flag>
+ </use>
+</pkgmetadata>
diff --git a/sys-auth/mrsh/mrsh-2.12.ebuild b/sys-auth/mrsh/mrsh-2.12.ebuild
new file mode 100644
index 000000000..6192a2b04
--- /dev/null
+++ b/sys-auth/mrsh/mrsh-2.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit systemd
+
+DESCRIPTION="Mrsh is a set of remote shell programs that use munge authentication."
+HOMEPAGE="https://github.com/chaos/mrsh"
+SRC_URI="https://github.com/chaos/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="pam shadow"
+DEPEND="
+ sys-auth/munge
+
+ pam? ( sys-libs/pam )
+ shadow? ( virtual/shadow )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/union-wait-deprecated.diff" )
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(use_with pam)
+ $(use_with shadow)
+ )
+ econf "${myconf[@]}"
+}