aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-02 22:51:32 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-02 23:03:53 +0100
commit0df5799804c272d796e18816c78f6a90aa1b218a (patch)
tree723bd6f837b15695f8c8e7243e09858f34a10c50 /sys-cluster
parentsys-cluster/rankstr: unconditionally depend on MPI (diff)
downloadguru-0df5799804c272d796e18816c78f6a90aa1b218a.tar.gz
guru-0df5799804c272d796e18816c78f6a90aa1b218a.tar.bz2
guru-0df5799804c272d796e18816c78f6a90aa1b218a.zip
sys-cluster/shuffile: unconditionally depend on MPI
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/shuffile/shuffile-0.0.3.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-cluster/shuffile/shuffile-0.0.3.ebuild b/sys-cluster/shuffile/shuffile-0.0.3.ebuild
index 5054b99cc..cb7febfa8 100644
--- a/sys-cluster/shuffile/shuffile-0.0.3.ebuild
+++ b/sys-cluster/shuffile/shuffile-0.0.3.ebuild
@@ -12,18 +12,19 @@ SRC_URI="https://github.com/ECP-VeloC/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="mpi test"
+IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
- mpi? ( virtual/mpi )
- sys-libs/zlib
>=sys-cluster/KVTree-1.0.2
+ sys-libs/zlib
+ virtual/mpi
"
DEPEND="${RDEPEND}"
BDEPEND="
>=dev-util/cmake-2.8
"
+
src_prepare() {
#do not build static library
sed -i '/shuffile-static/d' src/CMakeLists.txt || die
@@ -33,7 +34,7 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- -DMPI="$(usex mpi "" OFF)"
+ -DMPI="ON"
)
cmake-utils_src_configure
}