aboutsummaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAndrea Postiglione <andrea.postiglione@gmail.com>2020-08-13 15:17:22 +0200
committerAndrea Postiglione <andrea.postiglione@gmail.com>2020-08-13 15:17:22 +0200
commit60704677d22d590195150c1166f568c80ee7c663 (patch)
tree7e5a65fa113f92f910eb410d0f470f2e6184037f /sys-fs
parentapp-portage/version: fix tarball name (diff)
downloadguru-60704677d22d590195150c1166f568c80ee7c663.tar.gz
guru-60704677d22d590195150c1166f568c80ee7c663.tar.bz2
guru-60704677d22d590195150c1166f568c80ee7c663.zip
Add nss-tls-1.0 and gfs2-utils-3.2.0 ebuilds
Signed-off-by: Andrea Postiglione <andrea.postiglione@gmail.com>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/gfs2-utils/Manifest1
-rw-r--r--sys-fs/gfs2-utils/files/bashism.patch14
-rw-r--r--sys-fs/gfs2-utils/files/ftbfs-gcc9.patch185
-rw-r--r--sys-fs/gfs2-utils/files/gfs2_withdraw_helper.patch16
-rw-r--r--sys-fs/gfs2-utils/files/python3.patch21
-rw-r--r--sys-fs/gfs2-utils/files/reproducible.patch91
-rw-r--r--sys-fs/gfs2-utils/files/udev-rules.patch10
-rw-r--r--sys-fs/gfs2-utils/gfs2-utils-3.2.0.ebuild54
-rw-r--r--sys-fs/gfs2-utils/metadata.xml8
9 files changed, 400 insertions, 0 deletions
diff --git a/sys-fs/gfs2-utils/Manifest b/sys-fs/gfs2-utils/Manifest
new file mode 100644
index 000000000..5196b298b
--- /dev/null
+++ b/sys-fs/gfs2-utils/Manifest
@@ -0,0 +1 @@
+DIST gfs2-utils-3.2.0.tar.xz 279696 BLAKE2B bc8691396d820be09fbeeb590727d51fdcbfb739029a10bcbca501eb12fb4e1853d8dd9c70a0cb04fc1bad1c88be7520809b2bffa1d454f8d07923f6993629ed SHA512 77b5448d46a27ee77b14fe5437b7932233a25f1d189b407a440657591e44c1d0d77b6253003b8b92d7fc4e363fa6eab97e01f5ca8de2529d5c60a94917e9ef18
diff --git a/sys-fs/gfs2-utils/files/bashism.patch b/sys-fs/gfs2-utils/files/bashism.patch
new file mode 100644
index 000000000..67ed25224
--- /dev/null
+++ b/sys-fs/gfs2-utils/files/bashism.patch
@@ -0,0 +1,14 @@
+Description: Fix bashism in test script
+Author: Valentin Vidic <Valentin.Vidic@CARNet.hr>
+Last-Update: 2018-05-30
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/tests/rgrifieldscheck.sh
++++ b/tests/rgrifieldscheck.sh
+@@ -16,5 +16,5 @@
+ exit 1
+ fi
+
+- test $field = ri_bitbytes && let i++
++ test $field = ri_bitbytes && i=$((i+1))
+ done
diff --git a/sys-fs/gfs2-utils/files/ftbfs-gcc9.patch b/sys-fs/gfs2-utils/files/ftbfs-gcc9.patch
new file mode 100644
index 000000000..edf4a4d5f
--- /dev/null
+++ b/sys-fs/gfs2-utils/files/ftbfs-gcc9.patch
@@ -0,0 +1,185 @@
+commit 222e97c23dd015a8fc4bcceb598720cc17337edf
+Author: Andrew Price <anprice@redhat.com>
+Date: Mon Feb 4 14:54:34 2019 +0000
+
+ Fix libuuid linking
+
+ Fixes a build failure in Rawhide.
+
+ Signed-off-by: Andrew Price <anprice@redhat.com>
+
+diff --git a/gfs2/libgfs2/Makefile.am b/gfs2/libgfs2/Makefile.am
+index 749da85a..76df920e 100644
+--- a/gfs2/libgfs2/Makefile.am
++++ b/gfs2/libgfs2/Makefile.am
+@@ -54,8 +54,9 @@ libgfs2_la_CPPFLAGS = \
+ $(uuid_CFLAGS)
+
+ gfs2l_SOURCES = gfs2l.c
+-gfs2l_LDADD = libgfs2.la
+-gfs2l_LDFLAGS = $(uuid_LIBS)
++gfs2l_LDADD = \
++ libgfs2.la \
++ $(uuid_LIBS)
+ gfs2l_CPPFLAGS = \
+ -I$(top_srcdir)/gfs2/include \
+ -D_FILE_OFFSET_BITS=64
+commit 1a92a964c8ba87d95b2f43b0adc3d351a7f7ba80
+Author: Andrew Price <anprice@redhat.com>
+Date: Mon Feb 4 15:31:33 2019 +0000
+
+ Fix more linking errors
+
+ Signed-off-by: Andrew Price <anprice@redhat.com>
+
+diff --git a/gfs2/convert/Makefile.am b/gfs2/convert/Makefile.am
+index 4db643fb..2d61af74 100644
+--- a/gfs2/convert/Makefile.am
++++ b/gfs2/convert/Makefile.am
+@@ -7,5 +7,6 @@ gfs2_convert_CPPFLAGS = \
+ -I$(top_srcdir)/gfs2/include \
+ -I$(top_srcdir)/gfs2/libgfs2
+
+-gfs2_convert_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
+-gfs2_convert_LDFLAGS = $(uuid_LIBS)
++gfs2_convert_LDADD = \
++ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
++ $(uuid_LIBS)
+diff --git a/gfs2/edit/Makefile.am b/gfs2/edit/Makefile.am
+index a9b177e9..4a89502c 100644
+--- a/gfs2/edit/Makefile.am
++++ b/gfs2/edit/Makefile.am
+@@ -25,9 +25,9 @@ gfs2_edit_CFLAGS = \
+ $(zlib_CFLAGS) \
+ $(uuid_CFLAGS)
+
+-gfs2_edit_LDFLAGS = \
++gfs2_edit_LDADD = \
++ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
+ $(ncurses_LIBS) \
+ $(zlib_LIBS) \
+ $(uuid_LIBS)
+
+-gfs2_edit_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
+diff --git a/gfs2/fsck/Makefile.am b/gfs2/fsck/Makefile.am
+index 97fcd404..1c528051 100644
+--- a/gfs2/fsck/Makefile.am
++++ b/gfs2/fsck/Makefile.am
+@@ -36,6 +36,5 @@ fsck_gfs2_CPPFLAGS = \
+ -I$(top_srcdir)/gfs2/libgfs2
+
+ fsck_gfs2_LDADD = \
+- $(top_builddir)/gfs2/libgfs2/libgfs2.la
+-fsck_gfs2_LDFLAGS = \
++ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
+ $(uuid_LIBS)
+diff --git a/gfs2/glocktop/Makefile.am b/gfs2/glocktop/Makefile.am
+index 1102c8e2..f5076554 100644
+--- a/gfs2/glocktop/Makefile.am
++++ b/gfs2/glocktop/Makefile.am
+@@ -9,10 +9,6 @@ glocktop_SOURCES = \
+ glocktop_CFLAGS = \
+ $(ncurses_CFLAGS)
+
+-glocktop_LDFLAGS = \
+- $(ncurses_LIBS) \
+- $(uuid_LIBS)
+-
+ glocktop_CPPFLAGS = \
+ -D_FILE_OFFSET_BITS=64 \
+ -D_LARGEFILE64_SOURCE \
+@@ -21,4 +17,6 @@ glocktop_CPPFLAGS = \
+ -I$(top_srcdir)/gfs2/libgfs2
+
+ glocktop_LDADD = \
+- $(top_builddir)/gfs2/libgfs2/libgfs2.la
++ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
++ $(ncurses_LIBS) \
++ $(uuid_LIBS)
+diff --git a/gfs2/mkfs/Makefile.am b/gfs2/mkfs/Makefile.am
+index f0dd961c..fd7145b8 100644
+--- a/gfs2/mkfs/Makefile.am
++++ b/gfs2/mkfs/Makefile.am
+@@ -25,10 +25,10 @@ mkfs_gfs2_CPPFLAGS = $(COMMON_CPPFLAGS)
+ mkfs_gfs2_CFLAGS = \
+ $(blkid_CFLAGS) \
+ $(uuid_CFLAGS)
+-mkfs_gfs2_LDFLAGS = \
++mkfs_gfs2_LDADD = \
++ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
+ $(blkid_LIBS) \
+ $(uuid_LIBS)
+-mkfs_gfs2_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
+
+ gfs2_grow_SOURCES = \
+ main_grow.c \
+@@ -36,16 +36,17 @@ gfs2_grow_SOURCES = \
+
+ gfs2_grow_CPPFLAGS = $(COMMON_CPPFLAGS)
+ gfs2_grow_CFLAGS = $(blkid_CFLAGS)
+-gfs2_grow_LDFLAGS = \
++gfs2_grow_LDADD = \
++ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
+ $(blkid_LIBS) \
+ $(uuid_LIBS)
+-gfs2_grow_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
+
+ gfs2_jadd_SOURCES = \
+ main_jadd.c \
+ metafs.c
+
+ gfs2_jadd_CPPFLAGS = $(COMMON_CPPFLAGS)
+-gfs2_jadd_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
+-gfs2_jadd_LDFLAGS = $(uuid_LIBS)
++gfs2_jadd_LDADD = \
++ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
++ $(uuid_LIBS)
+
+diff --git a/gfs2/tune/Makefile.am b/gfs2/tune/Makefile.am
+index 7628f424..171377d0 100644
+--- a/gfs2/tune/Makefile.am
++++ b/gfs2/tune/Makefile.am
+@@ -13,5 +13,5 @@ tunegfs2_CPPFLAGS = \
+ -I$(top_srcdir)/group/include
+ tunegfs2_CFLAGS = \
+ $(uuid_CFLAGS)
+-tunegfs2_LDFLAGS = \
++tunegfs2_LDADD = \
+ $(uuid_LIBS)
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 40fcfb47..40b486b0 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -26,8 +26,7 @@ nukerg_CFLAGS = \
+ -I$(top_srcdir)/gfs2/libgfs2 \
+ -I$(top_srcdir)/gfs2/include
+ nukerg_LDADD = \
+- $(top_builddir)/gfs2/libgfs2/libgfs2.la
+-nukerg_LDFLAGS = \
++ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
+ $(uuid_LIBS)
+
+ if HAVE_CHECK
+@@ -54,16 +53,18 @@ check_meta_SOURCES = \
+ $(UNIT_SOURCES) \
+ check_meta.c
+ check_meta_CFLAGS = $(UNIT_CFLAGS)
+-check_meta_LDADD = $(UNIT_LDADD)
+-check_meta_LDFLAGS = $(uuid_LIBS)
++check_meta_LDADD = \
++ $(UNIT_LDADD) \
++ $(uuid_LIBS)
+ check_meta_CPPFLAGS = $(UNIT_CPPFLAGS)
+
+ check_rgrp_SOURCES = \
+ $(UNIT_SOURCES) \
+ check_rgrp.c
+ check_rgrp_CFLAGS = $(UNIT_CFLAGS)
+-check_rgrp_LDADD = $(UNIT_LDADD)
+-check_rgrp_LDFLAGS = $(uuid_LIBS)
++check_rgrp_LDADD = \
++ $(UNIT_LDADD) \
++ $(uuid_LIBS)
+ check_rgrp_CPPFLAGS = $(UNIT_CPPFLAGS)
+ endif
+
diff --git a/sys-fs/gfs2-utils/files/gfs2_withdraw_helper.patch b/sys-fs/gfs2-utils/files/gfs2_withdraw_helper.patch
new file mode 100644
index 000000000..9c4364a64
--- /dev/null
+++ b/sys-fs/gfs2-utils/files/gfs2_withdraw_helper.patch
@@ -0,0 +1,16 @@
+Description: update udev script to work in Debian
+Author: Valentin Vidic <Valentin.Vidic@CARNet.hr>
+Last-Update: 2018-04-05
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/gfs2/scripts/gfs2_withdraw_helper
++++ b/gfs2/scripts/gfs2_withdraw_helper
+@@ -19,7 +19,7 @@
+
+ if [ -z "$DM_DEV" ]
+ then
+- /usr/bin/dmsetup suspend $DM_DEV
++ /sbin/dmsetup suspend $DM_DEV
+ fi
+
+ # Signal completion of withdraw
diff --git a/sys-fs/gfs2-utils/files/python3.patch b/sys-fs/gfs2-utils/files/python3.patch
new file mode 100644
index 000000000..b90959aef
--- /dev/null
+++ b/sys-fs/gfs2-utils/files/python3.patch
@@ -0,0 +1,21 @@
+Description: update python scripts for python3
+Author: Valentin Vidic <Valentin.Vidic@CARNet.hr>
+Last-Update: 2018-04-05
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/gfs2/scripts/gfs2_lockcapture
++++ b/gfs2/scripts/gfs2_lockcapture
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python3
+ """
+ The script "gfs2_lockcapture" will capture locking information from GFS2 file
+ systems and DLM.
+--- a/gfs2/scripts/gfs2_trace
++++ b/gfs2/scripts/gfs2_trace
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/python3
+ """
+ This script will enable or disable trace events for GFS2. The script can capture
+ trace events and write the trace events captured to a file.
diff --git a/sys-fs/gfs2-utils/files/reproducible.patch b/sys-fs/gfs2-utils/files/reproducible.patch
new file mode 100644
index 000000000..9c957601f
--- /dev/null
+++ b/sys-fs/gfs2-utils/files/reproducible.patch
@@ -0,0 +1,91 @@
+Description: make build reproducible
+ Don't include build date and time in binaries.
+Author: Valentin Vidic <Valentin.Vidic@CARNet.hr>
+Last-Update: 2018-04-05
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/gfs2/convert/gfs2_convert.c
++++ b/gfs2/convert/gfs2_convert.c
+@@ -1699,8 +1699,7 @@
+ /* ------------------------------------------------------------------------- */
+ static void version(void)
+ {
+- log_notice(_("gfs2_convert version %s (built %s %s)\n"), VERSION,
+- __DATE__, __TIME__);
++ log_notice(_("gfs2_convert version %s\n"), VERSION);
+ log_notice("%s\n\n", REDHAT_COPYRIGHT);
+ }
+
+--- a/gfs2/edit/hexedit.c
++++ b/gfs2/edit/hexedit.c
+@@ -2396,8 +2396,8 @@
+ static void parameterpass1(int argc, char *argv[], int i)
+ {
+ if (!strcasecmp(argv[i], "-V")) {
+- printf("%s version %s (built %s %s)\n",
+- argv[0], VERSION, __DATE__, __TIME__);
++ printf("%s version %s\n",
++ argv[0], VERSION);
+ printf("%s\n", REDHAT_COPYRIGHT);
+ exit(0);
+ }
+--- a/gfs2/fsck/main.c
++++ b/gfs2/fsck/main.c
+@@ -62,8 +62,8 @@
+
+ static void version(void)
+ {
+- printf( _("GFS2 fsck %s (built %s %s)\n"),
+- VERSION, __DATE__, __TIME__);
++ printf( _("GFS2 fsck %s\n"),
++ VERSION);
+ printf(REDHAT_COPYRIGHT "\n");
+ }
+
+--- a/gfs2/mkfs/main_grow.c
++++ b/gfs2/mkfs/main_grow.c
+@@ -100,8 +100,7 @@
+ override_device_size <<= 20;
+ break;
+ case 'V':
+- printf(_("%s %s (built %s %s)\n"), argv[0],
+- VERSION, __DATE__, __TIME__);
++ printf(_("%s %s\n"), argv[0], VERSION);
+ printf(REDHAT_COPYRIGHT "\n");
+ exit(0);
+ case 'h':
+--- a/gfs2/mkfs/main_jadd.c
++++ b/gfs2/mkfs/main_jadd.c
+@@ -180,8 +180,7 @@
+ opts->quiet = 1;
+ break;
+ case 'V':
+- printf("gfs2_jadd %s (built %s %s)\n", VERSION,
+- __DATE__, __TIME__);
++ printf("gfs2_jadd %s\n", VERSION);
+ printf(REDHAT_COPYRIGHT "\n");
+ exit(0);
+ break;
+--- a/gfs2/mkfs/main_mkfs.c
++++ b/gfs2/mkfs/main_mkfs.c
+@@ -374,8 +374,7 @@
+ opt_parse_extended(optarg, opts);
+ break;
+ case 'V':
+- printf("mkfs.gfs2 %s (built %s %s)\n", VERSION,
+- __DATE__, __TIME__);
++ printf("mkfs.gfs2 %s\n", VERSION);
+ printf(REDHAT_COPYRIGHT "\n");
+ exit(EXIT_SUCCESS);
+ break;
+--- a/gfs2/tune/main.c
++++ b/gfs2/tune/main.c
+@@ -59,7 +59,7 @@
+
+ static void version(void)
+ {
+- printf("tunegfs2 (%s %s)\n", __DATE__, __TIME__);
++ printf("tunegfs2\n");
+ }
+
+ int main(int argc, char **argv)
diff --git a/sys-fs/gfs2-utils/files/udev-rules.patch b/sys-fs/gfs2-utils/files/udev-rules.patch
new file mode 100644
index 000000000..82d1f8384
--- /dev/null
+++ b/sys-fs/gfs2-utils/files/udev-rules.patch
@@ -0,0 +1,10 @@
+--- gfs2-utils-3.2.0/gfs2/scripts/Makefile.am 2018-05-23 22:04:16.000000000 +0200
++++ gfs2-utils-3.2.0.new/gfs2/scripts/Makefile.am 2020-02-10 15:16:08.262116412 +0100
+@@ -5,6 +5,6 @@
+ gfs2_trace \
+ gfs2_withdraw_helper
+
+-udevrulesdir=@udevdir@/rules.d
++udevrulesdir=/lib/udev/rules.d
+ dist_udevrules_DATA = \
+ 82-gfs2-withdraw.rules
diff --git a/sys-fs/gfs2-utils/gfs2-utils-3.2.0.ebuild b/sys-fs/gfs2-utils/gfs2-utils-3.2.0.ebuild
new file mode 100644
index 000000000..bfcd71c16
--- /dev/null
+++ b/sys-fs/gfs2-utils/gfs2-utils-3.2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs linux-info
+
+DESCRIPTION="Shared-disk cluster file system"
+HOMEPAGE="https://sourceware.org/cluster/gfs/"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="nls"
+
+RDEPEND="sys-libs/zlib
+ sys-apps/util-linux
+ sys-libs/ncurses"
+
+DEPEND="${RDEPEND}
+ sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/libtool
+ sys-devel/make
+ sys-devel/gettext
+ sys-devel/bison
+ sys-devel/flex
+ sys-libs/zlib"
+
+src_prepare() {
+ eapply "${FILESDIR}"/reproducible.patch
+ eapply "${FILESDIR}"/gfs2_withdraw_helper.patch
+ eapply "${FILESDIR}"/python3.patch
+ eapply "${FILESDIR}"/bashism.patch
+ eapply "${FILESDIR}"/ftbfs-gcc9.patch
+ eapply "${FILESDIR}"/udev-rules.patch
+ default
+ ./autogen.sh
+ eautoreconf
+}
+
+src_configure() {
+ econf
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
diff --git a/sys-fs/gfs2-utils/metadata.xml b/sys-fs/gfs2-utils/metadata.xml
new file mode 100644
index 000000000..55b9e5038
--- /dev/null
+++ b/sys-fs/gfs2-utils/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrea.postiglione@gmail.com</email>
+ <name>Andrea Postiglione</name>
+ </maintainer>
+</pkgmetadata>