aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@protonmail.com>2021-02-19 06:00:31 +0100
committerMaciej Barć <xgqt@protonmail.com>2021-02-19 06:00:31 +0100
commitbadcb046beedd37d9bf2347fee41061cb7c472c7 (patch)
treeb0082e08b66a36b6049e8d4cb2e3b160043eb992 /www-client
parentwww-client/torbrowser-launcher: drop old 0.3.2 version; hangs while launching (diff)
downloadguru-badcb046beedd37d9bf2347fee41061cb7c472c7.tar.gz
guru-badcb046beedd37d9bf2347fee41061cb7c472c7.tar.bz2
guru-badcb046beedd37d9bf2347fee41061cb7c472c7.zip
www-client/torbrowser-launcher: use optfeature
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@protonmail.com>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/torbrowser-launcher/torbrowser-launcher-0.3.3.ebuild6
-rw-r--r--www-client/torbrowser-launcher/torbrowser-launcher-9999.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/www-client/torbrowser-launcher/torbrowser-launcher-0.3.3.ebuild b/www-client/torbrowser-launcher/torbrowser-launcher-0.3.3.ebuild
index a5c71f21d..0694a09c3 100644
--- a/www-client/torbrowser-launcher/torbrowser-launcher-0.3.3.ebuild
+++ b/www-client/torbrowser-launcher/torbrowser-launcher-0.3.3.ebuild
@@ -6,7 +6,7 @@ EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1 xdg
+inherit distutils-r1 optfeature xdg
DESCRIPTION="A program to download, updated, and run the Tor Browser Bundle"
HOMEPAGE="https://github.com/micahflee/torbrowser-launcher"
@@ -49,5 +49,7 @@ python_install_all() {
pkg_postinst() {
xdg_pkg_postinst
- elog "For updating over system TOR install net-vpn/tor and dev-python/txsocksx"
+ elog "To get additional features, some optional runtime dependencies"
+ elog "may be installed:"
+ optfeature "updating over system TOR" net-vpn/tor dev-python/txsocksx
}
diff --git a/www-client/torbrowser-launcher/torbrowser-launcher-9999.ebuild b/www-client/torbrowser-launcher/torbrowser-launcher-9999.ebuild
index a5c71f21d..0694a09c3 100644
--- a/www-client/torbrowser-launcher/torbrowser-launcher-9999.ebuild
+++ b/www-client/torbrowser-launcher/torbrowser-launcher-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1 xdg
+inherit distutils-r1 optfeature xdg
DESCRIPTION="A program to download, updated, and run the Tor Browser Bundle"
HOMEPAGE="https://github.com/micahflee/torbrowser-launcher"
@@ -49,5 +49,7 @@ python_install_all() {
pkg_postinst() {
xdg_pkg_postinst
- elog "For updating over system TOR install net-vpn/tor and dev-python/txsocksx"
+ elog "To get additional features, some optional runtime dependencies"
+ elog "may be installed:"
+ optfeature "updating over system TOR" net-vpn/tor dev-python/txsocksx
}