aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2021-04-24 14:49:24 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2021-04-24 14:49:24 +0300
commit203e6852f620e793c5662129ca6e5a911496f652 (patch)
tree8eab4735707d8561554bd2d385a72cd6ffd9311a /x11-libs/gtk-fortran
parentx11-libs/gtk-fortran: drop 19.04 (diff)
downloadguru-203e6852f620e793c5662129ca6e5a911496f652.tar.gz
guru-203e6852f620e793c5662129ca6e5a911496f652.tar.bz2
guru-203e6852f620e793c5662129ca6e5a911496f652.zip
x11-libs/gtk-fortran: add USE="static-libs" conditional patch
Closes: https://bugs.gentoo.org/781812 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'x11-libs/gtk-fortran')
-rw-r--r--x11-libs/gtk-fortran/files/gtk-fortran-20.04_skip-static-build.patch32
-rw-r--r--x11-libs/gtk-fortran/gtk-fortran-20.04.ebuild4
2 files changed, 35 insertions, 1 deletions
diff --git a/x11-libs/gtk-fortran/files/gtk-fortran-20.04_skip-static-build.patch b/x11-libs/gtk-fortran/files/gtk-fortran-20.04_skip-static-build.patch
new file mode 100644
index 000000000..fb7cdd2cc
--- /dev/null
+++ b/x11-libs/gtk-fortran/files/gtk-fortran-20.04_skip-static-build.patch
@@ -0,0 +1,32 @@
+diff -Naur a/src/CMakeLists.txt b/src/CMakeLists.txt
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -73,17 +73,16 @@
+ endif()
+
+ #======================================================
+-# Defining the static and shared gtk-fortran libraries:
++# Defining the shared gtk-fortran libraries:
+ #======================================================
+ add_library(gtk-fortran_object OBJECT ${sources})
+ # To build position independent shared libraries:
+ set_property(TARGET gtk-fortran_object PROPERTY POSITION_INDEPENDENT_CODE TRUE)
+
+-add_library(gtk-fortran_static STATIC $<TARGET_OBJECTS:gtk-fortran_object>)
+ add_library(gtk-fortran_shared SHARED $<TARGET_OBJECTS:gtk-fortran_object>)
+ target_link_libraries(gtk-fortran_shared ${GTK_LIBRARIES})
+
+-set_target_properties(gtk-fortran_static gtk-fortran_shared PROPERTIES
++set_target_properties(gtk-fortran_shared PROPERTIES
+ OUTPUT_NAME ${gtk_V_fortran}
+ VERSION "0.1"
+ SOVERSION "0.1")
+@@ -131,7 +130,7 @@
+ #==================
+ # Files to install:
+ #==================
+-install(TARGETS gtk-fortran_static gtk-fortran_shared
++install(TARGETS gtk-fortran_shared
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
diff --git a/x11-libs/gtk-fortran/gtk-fortran-20.04.ebuild b/x11-libs/gtk-fortran/gtk-fortran-20.04.ebuild
index 8bb1099e1..02d8cd0a1 100644
--- a/x11-libs/gtk-fortran/gtk-fortran-20.04.ebuild
+++ b/x11-libs/gtk-fortran/gtk-fortran-20.04.ebuild
@@ -18,7 +18,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="examples high-level plplot"
+IUSE="examples high-level plplot static-libs"
REQUIRED_USE="plplot? ( high-level )"
RDEPEND="
@@ -43,6 +43,8 @@ src_prepare() {
sed -i -e "s:CMAKE_INSTALL_LIBDIR lib:CMAKE_INSTALL_LIBDIR $(get_libdir):" \
-e "s: add_subdirectory(sketcher)::" CMakeLists.txt || die
+ use !static-libs && eapply "${FILESDIR}/${P}_skip-static-build.patch"
+
cmake_src_prepare
}