aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/trio/Manifest2
-rw-r--r--dev-python/trio/trio-0.14.0-r1.ebuild67
-rw-r--r--dev-python/trio/trio-0.14.0.ebuild62
-rw-r--r--dev-python/trio/trio-0.15.1.ebuild62
4 files changed, 0 insertions, 193 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index 30d17868c..9a5ee6510 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,3 +1 @@
-DIST trio-0.14.0.tar.gz 451593 BLAKE2B 05b19fb17fb046c17c196d6fec003b731a0beb2c976e0d289665fbdf28c1ab8556404c21a9b3c72623b7d293a74438d4d43a368367838247d9e17e0f6d4ec47e SHA512 dcc640315c5f9a558c00be97ffc011bbb6d2a2137f4f07845698bdec5e2c0949ffb23f6ec49410e618d49156b42a5423b82f5c1f271c1cced7886d3f94c2cd9e
-DIST trio-0.15.1.tar.gz 457493 BLAKE2B 9123510032f8e59b67bde778c1270d0fd18771806120866741f4e03f6e3f354ad34d06d75b23f38d53fa43e0832cc51060049b81a35be14b4ce043e32672b77d SHA512 48ff7e00e67ad11d09faf643275982e893ee7d533396dd9fe2558d38390693acf9e023fddbc8b00b7d12090154c0610fa71e65d003e110cfbb47b3f0eb3e8469
DIST trio-0.17.0.tar.gz 488878 BLAKE2B bf24f5a80e7fed19a3efea833bd3336ebe3b164f495026913ec933e2b9f3150cdfc732bb029fb5d07b71523d811003cd8fa9fb487023c604b28c963d335adc55 SHA512 511c281aeefdd2197586aa1b3609836b06ac208cfac68b5e47af98ba9289e127899f45adc002c5750a9c868c214f04410e0077d34e20adbac5a9d0bf82b442fd
diff --git a/dev-python/trio/trio-0.14.0-r1.ebuild b/dev-python/trio/trio-0.14.0-r1.ebuild
deleted file mode 100644
index 2da462570..000000000
--- a/dev-python/trio/trio-0.14.0-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1 linux-info
-
-DESCRIPTION="Python library for async concurrency and I/O"
-HOMEPAGE="
- https://github.com/python-trio/trio
- https://pypi.org/project/trio
-"
-SRC_URI="https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( Apache-2.0 MIT )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/async_generator[${PYTHON_USEDEP}]
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/outcome[${PYTHON_USEDEP}]
- dev-python/sniffio[${PYTHON_USEDEP}]
- dev-python/sortedcontainers[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/contextvars[${PYTHON_USEDEP}]' python3_6)
-"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/jedi[${PYTHON_USEDEP}]
- dev-python/pylint[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- dev-python/yapf[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source \
- ">=dev-python/immutables-0.6" \
- dev-python/sphinxcontrib-trio \
- dev-python/sphinx_rtd_theme \
- dev-python/towncrier
-
-python_prepare_all() {
- # Disable tests require IPv6
- if ! linux_config_exists || ! linux_chkconfig_present IPV6; then
- sed -i -e "/for family in/s/, AF_INET6//" \
- -e "/test_getaddrinfo/i@pytest.mark.skip(reason='no IPv6')" \
- trio/tests/test_socket.py || die "sed failed for test_socket.py"
- fi
-
- # these tests require internet access
- rm trio/tests/test_ssl.py || die
- rm trio/tests/test_highlevel_ssl_helpers.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pytest -vv --deselect "trio/tests/test_exports.py::test_static_tool_sees_all_symbols[jedi-trio.socket]" || die
-}
diff --git a/dev-python/trio/trio-0.14.0.ebuild b/dev-python/trio/trio-0.14.0.ebuild
deleted file mode 100644
index 7a30e0378..000000000
--- a/dev-python/trio/trio-0.14.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 )
-
-inherit distutils-r1 linux-info
-
-DESCRIPTION="Python library for async concurrency and I/O"
-HOMEPAGE="
- https://github.com/python-trio/trio
- https://pypi.org/project/trio
-"
-SRC_URI="https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( Apache-2.0 MIT )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/async_generator[${PYTHON_USEDEP}]
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/outcome[${PYTHON_USEDEP}]
- dev-python/sniffio[${PYTHON_USEDEP}]
- dev-python/sortedcontainers[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/jedi[${PYTHON_USEDEP}]
- dev-python/pylint[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- dev-python/yapf[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source \
- ">=dev-python/immutables-0.6" \
- dev-python/sphinxcontrib-trio \
- dev-python/sphinx_rtd_theme \
- dev-python/towncrier
-
-python_prepare_all() {
- # Disable tests require IPv6
- if ! linux_config_exists || ! linux_chkconfig_present IPV6; then
- sed -i -e "/for family in/s/, AF_INET6//" \
- -e "/test_getaddrinfo/i@pytest.mark.skip(reason='no IPv6')" \
- trio/tests/test_socket.py || die "sed failed for test_socket.py"
- fi
-
- # these tests require internet access
- rm trio/tests/test_ssl.py || die
- rm trio/tests/test_highlevel_ssl_helpers.py || die
-
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/trio/trio-0.15.1.ebuild b/dev-python/trio/trio-0.15.1.ebuild
deleted file mode 100644
index 7a30e0378..000000000
--- a/dev-python/trio/trio-0.15.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 )
-
-inherit distutils-r1 linux-info
-
-DESCRIPTION="Python library for async concurrency and I/O"
-HOMEPAGE="
- https://github.com/python-trio/trio
- https://pypi.org/project/trio
-"
-SRC_URI="https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( Apache-2.0 MIT )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/async_generator[${PYTHON_USEDEP}]
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/outcome[${PYTHON_USEDEP}]
- dev-python/sniffio[${PYTHON_USEDEP}]
- dev-python/sortedcontainers[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/jedi[${PYTHON_USEDEP}]
- dev-python/pylint[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- dev-python/yapf[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source \
- ">=dev-python/immutables-0.6" \
- dev-python/sphinxcontrib-trio \
- dev-python/sphinx_rtd_theme \
- dev-python/towncrier
-
-python_prepare_all() {
- # Disable tests require IPv6
- if ! linux_config_exists || ! linux_chkconfig_present IPV6; then
- sed -i -e "/for family in/s/, AF_INET6//" \
- -e "/test_getaddrinfo/i@pytest.mark.skip(reason='no IPv6')" \
- trio/tests/test_socket.py || die "sed failed for test_socket.py"
- fi
-
- # these tests require internet access
- rm trio/tests/test_ssl.py || die
- rm trio/tests/test_highlevel_ssl_helpers.py || die
-
- distutils-r1_python_prepare_all
-}