aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/tekore/Manifest1
-rw-r--r--dev-python/tekore/tekore-1.7.0.ebuild35
2 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index 8d0a1f7dd..e158b1c48 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1,2 +1 @@
-DIST tekore-1.7.0.tar.gz 191852 BLAKE2B ca0be9e5b8f4e291de87d495098f295529c75457aca466627ab2d8973365a64b40f7a618883c0178ed6482ac4d62ef95d78341992404a4bbbec803fe939afcfb SHA512 a62b456621633e05edb39944e0cf36a0df092468c9e238f6028f8ea684613e37c32f5257d6fb681c758e01f451e2f3d0993f5fa9344463e9f12b5945add161b0
DIST tekore-2.1.3.tar.gz 202522 BLAKE2B 2328116cf0d25e2c55e9f68c38064293bfb3e0d5361d02a7ed9f79a723ede54afeee2a355949ea619c56f02b242497a58044704197b757530cf51273b6970cc4 SHA512 d0895cdeee442bda19aecccd0cc2bd4022284972c535dac42d1aaa3c1e2b6676e9d80515cee44c555e6180b2b81a007fa43e77cb44f81c90e06aad6c6410d981
diff --git a/dev-python/tekore/tekore-1.7.0.ebuild b/dev-python/tekore/tekore-1.7.0.ebuild
deleted file mode 100644
index 67deaf4eb..000000000
--- a/dev-python/tekore/tekore-1.7.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Spotify Web API client"
-HOMEPAGE="https://tekore.readthedocs.io
- https://github.com/felix-hilden/tekore"
-SRC_URI="https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-
-RDEPEND="
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/httpx-0.11.1[${PYTHON_USEDEP}]
- <dev-python/httpx-0.13[${PYTHON_USEDEP}]
- media-sound/spotify
-"
-
-DOCS="readme.rst"
-
-distutils_enable_tests pytest
-# doc not working: 'PosixPath' object has no attribute 'rstrip'
-#distutils_enable_sphinx docs/src dev-python/sphinx_rtd_theme dev-python/sphinx-autodoc-typehints
-
-#need this, otherwise: no tests ran
-python_test() {
- pytest -vv tests/* || die "Tests fail with ${EPYTHON}"
-}