aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/sanic/Manifest3
-rw-r--r--dev-python/sanic/sanic-19.12.2.ebuild51
-rw-r--r--dev-python/sanic/sanic-20.6.3.ebuild (renamed from dev-python/sanic/sanic-20.3.0.ebuild)13
3 files changed, 7 insertions, 60 deletions
diff --git a/dev-python/sanic/Manifest b/dev-python/sanic/Manifest
index 30b9cc758..aa86a6d2c 100644
--- a/dev-python/sanic/Manifest
+++ b/dev-python/sanic/Manifest
@@ -1,2 +1 @@
-DIST sanic-19.12.2.tar.gz 195755 BLAKE2B 0d903b06403f28a901d21bfc685219064d0ec2b11576baf714aa3250cc3474928da03c34f0a5a25bf92191242b0a41f76d41aabe92a805bea1801e569c892e9a SHA512 93e416ceea5577db4c443dd6dd03cc5e990d4f987d49821b70d5602421d38401e155e2aad166c88ec57fc5361350c641f087b461a6d92acde34455db81429c5c
-DIST sanic-20.3.0.tar.gz 200120 BLAKE2B 14c648f6607b924ee8c19a481b027866a1e24b13249129d3e3fd2ebaf48243ec30d800cd0f62f3f361ae265ef4139676b5aaa4d5481e57459360df11d9fb5c8d SHA512 05615b2b0a2f3b03b2cdf6cff9d2df6f95a54c12be98b54674a2060104327e9a98db55b5e9fbc608f4e624abbb68e7b2f169df26c8197669aad05a4e15ac3ee7
+DIST sanic-20.6.3.tar.gz 207406 BLAKE2B 323f9d0d4965ee8fab4ffb95140f85d059f1bba777f36cc69703b7569c29a852631dd446dd0469207e8ccca3636aa45acfb6b50f290c6ddcc4f56249683a12b7 SHA512 c2b3eafcaee77e75b603e62feeb397382b2017d80191507a43db2595cc64e8b37b569b204474f94f5bdaae909c83baca7d7667ef46a0dd7324991efe15b22ebf
diff --git a/dev-python/sanic/sanic-19.12.2.ebuild b/dev-python/sanic/sanic-19.12.2.ebuild
deleted file mode 100644
index 45084503c..000000000
--- a/dev-python/sanic/sanic-19.12.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Async Python 3.6+ web server/framework | Build fast. Run fast."
-HOMEPAGE="
- https://pypi.python.org/pypi/sanic
- https://github.com/huge-success/sanic
-"
-SRC_URI="https://github.com/huge-success/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/aiofiles[${PYTHON_USEDEP}]
- ~dev-python/httpx-0.9.3[${PYTHON_USEDEP}]
- >=dev-python/httptools-0.0.10[${PYTHON_USEDEP}]
- >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
- <dev-python/multidict-5.0[${PYTHON_USEDEP}]
- dev-python/uvloop[${PYTHON_USEDEP}]
- dev-python/ujson[${PYTHON_USEDEP}]
- >=dev-python/websockets-7.0[${PYTHON_USEDEP}]
- <dev-python/websockets-9.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- test? (
- dev-python/beautifulsoup[${PYTHON_USEDEP}]
- dev-python/httpcore[${PYTHON_USEDEP}]
- dev-python/pytest-benchmark[${PYTHON_USEDEP}]
- dev-python/pytest-sanic[${PYTHON_USEDEP}]
- dev-python/pytest-sugar[${PYTHON_USEDEP}]
- dev-python/uvicorn[${PYTHON_USEDEP}]
- www-servers/gunicorn[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/docutils \
- dev-python/pygments \
- ">=dev-python/sphinx-2.1.2" \
- dev-python/sphinx_rtd_theme \
- ">=dev-python/recommonmark-0.5.0"
diff --git a/dev-python/sanic/sanic-20.3.0.ebuild b/dev-python/sanic/sanic-20.6.3.ebuild
index 15a52d73c..5db11eb05 100644
--- a/dev-python/sanic/sanic-20.3.0.ebuild
+++ b/dev-python/sanic/sanic-20.6.3.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_7 )
inherit distutils-r1
@@ -20,15 +20,14 @@ KEYWORDS="~amd64 ~x86"
RDEPEND="
dev-python/aiofiles[${PYTHON_USEDEP}]
- >=dev-python/httpx-0.11.1[${PYTHON_USEDEP}]
- <dev-python/httpx-0.12[${PYTHON_USEDEP}]
+ ~dev-python/httpx-0.11.1[${PYTHON_USEDEP}]
>=dev-python/httptools-0.0.10[${PYTHON_USEDEP}]
>=dev-python/multidict-4.0[${PYTHON_USEDEP}]
<dev-python/multidict-5.0[${PYTHON_USEDEP}]
- >=dev-python/ujson-1.35[${PYTHON_USEDEP}]
- >=dev-python/uvloop-0.5.3[${PYTHON_USEDEP}]
- >=dev-python/websockets-7.0[${PYTHON_USEDEP}]
- <dev-python/websockets-8.0[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}]
+ >=dev-python/websockets-8.1[${PYTHON_USEDEP}]
+ <dev-python/websockets-9.0[${PYTHON_USEDEP}]
"
DEPEND="
${RDEPEND}