aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/customrescuecd-x86-grub/customrescuecd-x86-grub-0.1.ebuild31
-rw-r--r--sys-boot/customrescuecd-x86-grub/files/customrescuecd.default7
-rw-r--r--sys-boot/customrescuecd-x86-grub/files/customrescuecd.grub43
-rw-r--r--sys-boot/customrescuecd-x86-grub/metadata.xml17
4 files changed, 98 insertions, 0 deletions
diff --git a/sys-boot/customrescuecd-x86-grub/customrescuecd-x86-grub-0.1.ebuild b/sys-boot/customrescuecd-x86-grub/customrescuecd-x86-grub-0.1.ebuild
new file mode 100644
index 000000000..7c076161b
--- /dev/null
+++ b/sys-boot/customrescuecd-x86-grub/customrescuecd-x86-grub-0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Grub menu entries for the .iso image of customrescuecd"
+HOMEPAGE="https://sourceforge.net/projects/customrescuecd/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT=0
+KEYWORDS="~x86"
+
+S=${WORKDIR}
+
+RDEPEND="app-admin/customrescuecd-x86
+ sys-boot/grub"
+
+src_install() {
+ exeinto /etc/grub.d
+ newexe "${FILESDIR}"/customrescuecd.grub 39_customrescuecd
+
+ insinto /etc/default
+ newins "${FILESDIR}"/customrescuecd.default customrescuecd
+}
+
+pkg_postinst() {
+ elog "To add the menu entries for customrescuecd to grub, you should now run"
+ elog " grub-mkconfig -o /boot/grub/grub.cfg"
+ elog "You can set custom bootoptions in /etc/default/customrescuecd"
+}
diff --git a/sys-boot/customrescuecd-x86-grub/files/customrescuecd.default b/sys-boot/customrescuecd-x86-grub/files/customrescuecd.default
new file mode 100644
index 000000000..ce093e352
--- /dev/null
+++ b/sys-boot/customrescuecd-x86-grub/files/customrescuecd.default
@@ -0,0 +1,7 @@
+Here you can set custom bootoptions for the CustomRescueCD
+#
+# You can add for example in a space separated list:
+# copytoram: causes the iso file to be fully loaded into memory
+# this requires 1.5G of memory to cache everything
+#
+CRCD_BOOTOPTIONS=""
diff --git a/sys-boot/customrescuecd-x86-grub/files/customrescuecd.grub b/sys-boot/customrescuecd-x86-grub/files/customrescuecd.grub
new file mode 100644
index 000000000..7c5965d8c
--- /dev/null
+++ b/sys-boot/customrescuecd-x86-grub/files/customrescuecd.grub
@@ -0,0 +1,43 @@
+#!/bin/sh
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+. /usr/share/grub/grub-mkconfig_lib
+
+if [ -r /etc/default/customrescuecd ] ; then
+ . /etc/default/customrescuecd
+fi
+
+# srcd = path of newest link to iso of customrescuecd, created by the ebuild
+# of customrescuecd-x86
+
+crcd="/usr/share/systemrescuecd/systemrescuecd-x86-newest.iso"
+
+longname="CustomRescueCD"
+bootops=")"
+
+if [ ! -z "${CRCD_BOOTOPTIONS}" ]; then
+ bootops=" with bootoptions)"
+fi
+
+if [ -f "${crcd}" ]; then
+
+ device=$(${grub_probe} --target=device "${crcd}")
+ path=$(make_system_path_relative_to_its_root "${crcd}")
+ grub_string=$(prepare_grub_to_access_device "${device}" | grub_add_tab | grub_add_tab)
+
+ gettext_printf "Found %s on %s\n" "${longname}" "${device}" >&2
+ onstr=$(gettext_printf "(on %s)" "${device}")
+
+ cat << EOF
+submenu "${longname}" --class submenu {
+ menuentry "${longname} (32bit standard${bootops}" --class rescue {
+${grub_string}
+ set isofile=${path}
+ loopback loop \${isofile}
+ linux (loop)/boot/x86/customrescue32 ${CRCD_BOOTOPTIONS} customisobasedir=customresccd customisolabel=CRC32 vga=791 net.ifnames=0
+ }
+}
+EOF
+
+fi
diff --git a/sys-boot/customrescuecd-x86-grub/metadata.xml b/sys-boot/customrescuecd-x86-grub/metadata.xml
new file mode 100644
index 000000000..2e146c34f
--- /dev/null
+++ b/sys-boot/customrescuecd-x86-grub/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoobugs@milaw.biz</email>
+ <name>Michael Lange</name>
+ <description>Accepts only mails from Gentoo's Bugzilla</description>
+ </maintainer>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <longdescription>
+ This package adds menu entries in GRUB for the SystemRescueCD. You can
+ add custom bootoptions for SystemRescueCD in a special config file.
+ </longdescription>
+</pkgmetadata>