aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/micro/micro-2.0.9.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/app-editors/micro/micro-2.0.9.ebuild b/app-editors/micro/micro-2.0.9.ebuild
index 2dc1b350b8..ce31b3d2db 100644
--- a/app-editors/micro/micro-2.0.9.ebuild
+++ b/app-editors/micro/micro-2.0.9.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit go-module
+inherit go-module optfeature
EGO_SUM=(
"github.com/blang/semver v3.5.1+incompatible"
@@ -97,7 +97,7 @@ EGO_SUM=(
go-module_set_globals
-DESCRIPTION="A modern and intuitive terminal-based text editor"
+DESCRIPTION="Modern and intuitive terminal-based text editor"
HOMEPAGE="https://github.com/zyedidia/micro"
SRC_URI="
https://github.com/zyedidia/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
@@ -107,17 +107,8 @@ SRC_URI="
LICENSE="MIT Apache-2.0 BSD BSD-2 MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="wayland"
RESTRICT="mirror"
-RDEPEND="
- !wayland? (
- x11-misc/xsel
- x11-misc/xclip
- )
- wayland? ( gui-apps/wl-clipboard )
-"
-
src_compile() {
go build -v -work -x -o ${PN} ./cmd/micro || die
}
@@ -127,3 +118,9 @@ src_install() {
doman ./assets/packaging/micro.1
einstalldocs
}
+
+pkg_postinst() {
+ optfeature_header "Clipboard support with display servers:"
+ optfeature "Xorg" x11-misc/xsel x11-misc/xclip
+ optfeature "Wayland" gui-apps/wl-clipboard
+}