aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-emulation/melonds/Manifest2
-rw-r--r--games-emulation/melonds/melonds-0.8.3.ebuild54
-rw-r--r--games-emulation/melonds/melonds-0.9.ebuild59
-rw-r--r--games-emulation/melonds/melonds-9999.ebuild59
-rw-r--r--games-emulation/melonds/metadata.xml15
5 files changed, 189 insertions, 0 deletions
diff --git a/games-emulation/melonds/Manifest b/games-emulation/melonds/Manifest
new file mode 100644
index 000000000..cc555a3e9
--- /dev/null
+++ b/games-emulation/melonds/Manifest
@@ -0,0 +1,2 @@
+DIST melonDS-0.8.3.tar.gz 965501 BLAKE2B 6ada01de8942c7ae5ec4a0a48cc76384ac2196f567d67d242d3d81e7c760dd87d76fcb5a33b540b670fd79358ba8e6a9c355d48e8eb08c721dfe33b54e4a9842 SHA512 4fed77abd231812d2f9ddb19a7fe6e808fb8e92035bb2fea220032b7c0a98671b4fd79ef0f7c7c559e92f3d1875ea119afaa581be2edacaa10f4437620eecd76
+DIST melonDS-0.9.tar.gz 899619 BLAKE2B 4a3fe0c8ca1cce9ed823f74eaf58786f8847b62e0e25d5f0e97b1cc0e68754b61a09b5e9b790264549377011dd899447fbe715ca2831320a903d70e24953b3dd SHA512 7d65058f9140c1bbcdc17d32aee62625023dba8c3c45665486c8a3dbec551ca109831949716eadb8048921464d4a6543698b741835b32cc95a96f5b5cf885e04
diff --git a/games-emulation/melonds/melonds-0.8.3.ebuild b/games-emulation/melonds/melonds-0.8.3.ebuild
new file mode 100644
index 000000000..ddd580738
--- /dev/null
+++ b/games-emulation/melonds/melonds-0.8.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="melonDS"
+MY_P="${MY_PN}-${PV}"
+
+inherit xdg cmake
+
+DESCRIPTION="Nintendo DS emulator, sorta"
+HOMEPAGE="http://melonds.kuribo64.net/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Arisotura/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/Arisotura/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+RESTRICT="mirror"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ media-libs/libsdl2[sound,video]
+ net-libs/libpcap
+ net-misc/curl
+ x11-libs/cairo
+ x11-libs/gtk+:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ elog "You need the following files in order to run melonDS:"
+ elog "- bios7.bin"
+ elog "- bios9.bin"
+ elog "- firmware.bin"
+ elog "- romlist.bin"
+ elog "Place them in ~/.config/melonDS"
+ elog "The romlist.bin file can be found in the /usr/share/melonDS directory"
+ elog "The rest of those files can be found somewhere in the internet ;-)"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
diff --git a/games-emulation/melonds/melonds-0.9.ebuild b/games-emulation/melonds/melonds-0.9.ebuild
new file mode 100644
index 000000000..d7c1be9b7
--- /dev/null
+++ b/games-emulation/melonds/melonds-0.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="melonDS"
+MY_P="${MY_PN}-${PV}"
+
+inherit xdg cmake
+
+DESCRIPTION="Nintendo DS emulator, sorta"
+HOMEPAGE="http://melonds.kuribo64.net/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Arisotura/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/Arisotura/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+RESTRICT="mirror"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/libsdl2[sound,video]
+ net-libs/gnutls
+ net-libs/libpcap
+ net-libs/libslirp
+ net-misc/curl
+ x11-libs/cairo
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "You need the following files in order to run melonDS:"
+ elog "- bios7.bin"
+ elog "- bios9.bin"
+ elog "- firmware.bin"
+ elog "- romlist.bin"
+ elog "Place them in ~/.config/melonDS"
+ elog "Those files can be found somewhere on the Internet ;-)"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
diff --git a/games-emulation/melonds/melonds-9999.ebuild b/games-emulation/melonds/melonds-9999.ebuild
new file mode 100644
index 000000000..d7c1be9b7
--- /dev/null
+++ b/games-emulation/melonds/melonds-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="melonDS"
+MY_P="${MY_PN}-${PV}"
+
+inherit xdg cmake
+
+DESCRIPTION="Nintendo DS emulator, sorta"
+HOMEPAGE="http://melonds.kuribo64.net/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Arisotura/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/Arisotura/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+RESTRICT="mirror"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/libsdl2[sound,video]
+ net-libs/gnutls
+ net-libs/libpcap
+ net-libs/libslirp
+ net-misc/curl
+ x11-libs/cairo
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "You need the following files in order to run melonDS:"
+ elog "- bios7.bin"
+ elog "- bios9.bin"
+ elog "- firmware.bin"
+ elog "- romlist.bin"
+ elog "Place them in ~/.config/melonDS"
+ elog "Those files can be found somewhere on the Internet ;-)"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
diff --git a/games-emulation/melonds/metadata.xml b/games-emulation/melonds/metadata.xml
new file mode 100644
index 000000000..47bb6532a
--- /dev/null
+++ b/games-emulation/melonds/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@protonmail.com</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">Arisotura/melonDS</remote-id>
+ </upstream>
+ <longdescription>
+ DS emulator, sorta.
+ The goal is to do things right and fast, akin to blargSNES.
+ </longdescription>
+</pkgmetadata>