aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.14.3.ebuild49
-rw-r--r--net-misc/gallery-dl/gallery-dl-9999.ebuild49
-rw-r--r--net-misc/gallery-dl/metadata.xml14
4 files changed, 113 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
new file mode 100644
index 000000000..d505f1205
--- /dev/null
+++ b/net-misc/gallery-dl/Manifest
@@ -0,0 +1 @@
+DIST v1.14.3.tar.gz 317004 BLAKE2B 9ff327dde9e4fb361e87e40b835cf5324f639b0f2d61ff762854d685a381c0f2b098545c295eae0b92fdb67aea23cd03379af3bae22a9a928e4dcb3d5b40f689 SHA512 66971ed49c7d90bf249fe5b48848c05f2e085cca04a448fd818b69a0fcd27b8739414ec506f429ef4ca9ae45f7a8919fdfefbd9206bb5bb475ca3e783f5ef494
diff --git a/net-misc/gallery-dl/gallery-dl-1.14.3.ebuild b/net-misc/gallery-dl/gallery-dl-1.14.3.ebuild
new file mode 100644
index 000000000..3d34bec5a
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.14.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6,7,8})
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="bash-completion zsh-completion"
+
+RDEPEND="
+ >=dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+"
+
+# tests require network access
+#distutils_enable_tests setup.py
+
+src_compile() {
+ if use bash-completion || use zsh-completion
+ then
+ emake completion
+ fi
+
+ emake man
+
+ # this will install shell completion and man pages generated above (if any)
+ distutils-r1_src_compile
+}
+
+pkg_postinst() {
+ elog "Optionad dependencies:"
+ elog "media-video/ffmpeg - for Pixiv Ugoira to WebM conversion"
+ elog "net-misc/youtube-dl - for video downloads"
+}
diff --git a/net-misc/gallery-dl/gallery-dl-9999.ebuild b/net-misc/gallery-dl/gallery-dl-9999.ebuild
new file mode 100644
index 000000000..3d34bec5a
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6,7,8})
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="bash-completion zsh-completion"
+
+RDEPEND="
+ >=dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+"
+
+# tests require network access
+#distutils_enable_tests setup.py
+
+src_compile() {
+ if use bash-completion || use zsh-completion
+ then
+ emake completion
+ fi
+
+ emake man
+
+ # this will install shell completion and man pages generated above (if any)
+ distutils-r1_src_compile
+}
+
+pkg_postinst() {
+ elog "Optionad dependencies:"
+ elog "media-video/ffmpeg - for Pixiv Ugoira to WebM conversion"
+ elog "net-misc/youtube-dl - for video downloads"
+}
diff --git a/net-misc/gallery-dl/metadata.xml b/net-misc/gallery-dl/metadata.xml
new file mode 100644
index 000000000..534685277
--- /dev/null
+++ b/net-misc/gallery-dl/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@protonmail.com</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cdr/code-server</remote-id>
+ </upstream>
+ <longdescription>
+gallery-dl is a command-line program to download image-galleries and -collections from several image hosting sites (see Supported Sites). It is a cross-platform tool with many configuration options and powerful filenaming capabilities.
+ </longdescription>
+</pkgmetadata>