aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/aiomysql/Manifest2
-rw-r--r--dev-python/aiomysql/aiomysql-0.0.20.ebuild29
2 files changed, 19 insertions, 12 deletions
diff --git a/dev-python/aiomysql/Manifest b/dev-python/aiomysql/Manifest
index 05ae677593..559110322e 100644
--- a/dev-python/aiomysql/Manifest
+++ b/dev-python/aiomysql/Manifest
@@ -1 +1 @@
-DIST aiomysql-0.0.20.tar.gz 36740 BLAKE2B 6841de8317c6b18c0268b242e816ca42d263aeb6e5803eab39dbc4b001e6f702472c3dc25cd83d04771891e66c2999c9cccb89995956c4d52840dce175d8ab6e SHA512 02a493391d411271e3457b04039e8a5c6c3c7634875171adbd9bc1bc3d6eb55e62b09f9a3edb895a08e0318c0f279bfbfe88f1e45fb1509b1b75259ff8a3e06f
+DIST aiomysql-0.0.20.tar.gz 97327 BLAKE2B fddcbf669a7da14605a038dcb57ad01b32c41a5693ef1cdc6fab7c72d3eadd9e937671e82e5c6015f22ec0f1903dbaf1076adb168c799e93a1d3985e73e714c9 SHA512 d182a638675e147bac5bc82826063e67376b97a4f58963991ad1146f97fc3bda0080a42cb7f2b826fd01b43797fc105c9ead50ab3f130f2ea08127a49c868164
diff --git a/dev-python/aiomysql/aiomysql-0.0.20.ebuild b/dev-python/aiomysql/aiomysql-0.0.20.ebuild
index bcc14bedcf..e84e167842 100644
--- a/dev-python/aiomysql/aiomysql-0.0.20.ebuild
+++ b/dev-python/aiomysql/aiomysql-0.0.20.ebuild
@@ -3,16 +3,16 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
DESCRIPTION="aiomysql is a library for accessing a MySQL database from the asyncio"
HOMEPAGE="
- https://aiomysql.readthedocs.io/en/latest/
- https://github.com/aio-libs/aiomysql
+ https://aiomysql.readthedocs.io/en/latest/
+ https://github.com/aio-libs/aiomysql
"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -20,12 +20,19 @@ KEYWORDS="~amd64 ~x86"
RDEPEND=">=dev-python/pymysql-0.9.0[${PYTHON_USEDEP}]"
-DEPEND="test? ( dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-asyncio[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/uvloop[${PYTHON_USEDEP}] )"
+DEPEND="test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/docker-py[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # fails: lots of AttributeError
+ rm tests/conftest.py || die
+
+ distutils-r1_python_prepare_all
+}
distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinxcontrib-asyncio