aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/autoflake/Manifest2
-rw-r--r--dev-python/autoflake/autoflake-1.4-r1.ebuild14
2 files changed, 7 insertions, 9 deletions
diff --git a/dev-python/autoflake/Manifest b/dev-python/autoflake/Manifest
index 1c009f0b6..488179638 100644
--- a/dev-python/autoflake/Manifest
+++ b/dev-python/autoflake/Manifest
@@ -1 +1 @@
-DIST autoflake-1.4.tar.gz 24219 BLAKE2B 622c82b9ab5e7fd68e8bc2678c5868282e605640e1c52d1a8f81fbaaba26dfb738ac1ceb9eb20195bb820256fbae27222953a5271130e74b8708988516e20e00 SHA512 53e542a765cbd18df7c35a90f16786e173bdc332b4410abfbc6d24f1009bf5d6f8a383e897e72558617bdf339573d8aa9b8de6901aac392caf48889aacf0c9a6
+DIST autoflake-1.4.gh.tar.gz 24219 BLAKE2B 622c82b9ab5e7fd68e8bc2678c5868282e605640e1c52d1a8f81fbaaba26dfb738ac1ceb9eb20195bb820256fbae27222953a5271130e74b8708988516e20e00 SHA512 53e542a765cbd18df7c35a90f16786e173bdc332b4410abfbc6d24f1009bf5d6f8a383e897e72558617bdf339573d8aa9b8de6901aac392caf48889aacf0c9a6
diff --git a/dev-python/autoflake/autoflake-1.4-r1.ebuild b/dev-python/autoflake/autoflake-1.4-r1.ebuild
index c4e72bbf2..4ba57124c 100644
--- a/dev-python/autoflake/autoflake-1.4-r1.ebuild
+++ b/dev-python/autoflake/autoflake-1.4-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="Removes unused imports and unused variables as reported by pyflakes"
@@ -12,17 +12,15 @@ HOMEPAGE="
https://github.com/myint/autoflake
https://pypi.org/project/autoflake/
"
-SRC_URI="https://github.com/myint/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/myint/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-DEPEND=">=dev-python/pyflakes-1.1.0[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND=">=dev-python/pyflakes-1.1.0[${PYTHON_USEDEP}]"
-RESTRICT="!test? ( test )"
+distutils_enable_tests setup.py
python_test() {
"${EPYTHON}" test_autoflake.py || die