aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/stdman/stdman-2019.08.27.ebuild')
-rw-r--r--app-text/stdman/stdman-2019.08.27.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/stdman/stdman-2019.08.27.ebuild b/app-text/stdman/stdman-2019.08.27.ebuild
new file mode 100644
index 000000000..17a511f94
--- /dev/null
+++ b/app-text/stdman/stdman-2019.08.27.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="Formatted C++ stdlib man pages (cppreference)"
+HOMEPAGE="https://github.com/jeaye/stdman"
+LICENSE="MIT"
+
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${PN}-dont-compress-files.patch" )
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jeaye/stdman"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/jeaye/stdman/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_compile() {
+ # don't need to compile anything
+ true
+}