aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/stdman/Manifest1
-rw-r--r--app-text/stdman/stdman-2019.08.27.ebuild30
-rw-r--r--app-text/stdman/stdman-9999.ebuild2
3 files changed, 33 insertions, 0 deletions
diff --git a/app-text/stdman/Manifest b/app-text/stdman/Manifest
new file mode 100644
index 000000000..d7e6acf06
--- /dev/null
+++ b/app-text/stdman/Manifest
@@ -0,0 +1 @@
+DIST stdman-2019.08.27.tar.gz 3382896 BLAKE2B 9c2665a80658b4a4023a259c183c2cb81ba8d6bc60b22e4fc7246d8eff28f9ed96f5acae1a7ce6cd1c6e7f4c7e57719b76d0e840b92d2c6cefa03ed380a66ef8 SHA512 8024117fb16ba65e6d5721f4c74701f683c032e758806ddb40a7a35bd0478379a925517cd2ee9ad2c74d30a6ce1df279393e43b9361fabb9a631cf91dacb4821
diff --git a/app-text/stdman/stdman-2019.08.27.ebuild b/app-text/stdman/stdman-2019.08.27.ebuild
new file mode 100644
index 000000000..17a511f94
--- /dev/null
+++ b/app-text/stdman/stdman-2019.08.27.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="Formatted C++ stdlib man pages (cppreference)"
+HOMEPAGE="https://github.com/jeaye/stdman"
+LICENSE="MIT"
+
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${PN}-dont-compress-files.patch" )
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jeaye/stdman"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/jeaye/stdman/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_compile() {
+ # don't need to compile anything
+ true
+}
diff --git a/app-text/stdman/stdman-9999.ebuild b/app-text/stdman/stdman-9999.ebuild
index 70d173736..16dde78c0 100644
--- a/app-text/stdman/stdman-9999.ebuild
+++ b/app-text/stdman/stdman-9999.ebuild
@@ -19,6 +19,8 @@ PATCHES=( "${FILESDIR}/${PN}-dont-compress-files.patch" )
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/jeaye/stdman"
+else
+ SRC_URI="https://github.com/jeaye/stdman/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi
src_compile() {