aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/olm/olm-3.2.4.ebuild')
-rw-r--r--dev-libs/olm/olm-3.2.4.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-libs/olm/olm-3.2.4.ebuild b/dev-libs/olm/olm-3.2.4.ebuild
deleted file mode 100644
index 4247affec..000000000
--- a/dev-libs/olm/olm-3.2.4.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Implementation of the olm and megolm cryptographic ratchets"
-HOMEPAGE="https://gitlab.matrix.org/matrix-org/olm"
-SRC_URI="https://gitlab.matrix.org/matrix-org/${PN}/-/archive/${PV}/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-src_configure() {
- local -a mycmakeargs=(
- -DOLM_TESTS="$(usex test)"
- )
-
- cmake_src_configure
-}
-
-src_test() {
- BUILD_DIR="${BUILD_DIR}/tests" cmake_src_test
-}
-
-src_install() {
- use doc && DOCS=( README.md docs/{{,meg}olm,signing}.md )
-
- cmake_src_install
-}