aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pymilter/pymilter-1.0.3.ebuild')
-rw-r--r--dev-python/pymilter/pymilter-1.0.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pymilter/pymilter-1.0.3.ebuild b/dev-python/pymilter/pymilter-1.0.3.ebuild
new file mode 100644
index 000000000..9bc7d8423
--- /dev/null
+++ b/dev-python/pymilter/pymilter-1.0.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to sendmail milter API"
+HOMEPAGE="https://github.com/sdgathman/pymilter"
+SRC_URI="https://github.com/sdgathman/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${P}"
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v
+}