aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.11.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index 8ec7c200f..b36be84ca 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1 +1,2 @@
DIST sphinx-autodoc-typehints-1.10.3.tar.gz 16396 BLAKE2B 5621e6225fa8f97f61a3e7ad387631bc524bd4cd236a184e88431dd044dbf208b042882a150a88372f7bdd613d06de980a5b6685ed1814c6b0c7c1a27079f715 SHA512 170fd6cea10d730eefeef4e2e4de985119dbcde06d43181bb522ec31923ddc49dd7757ca623c820e2e5008198ef9b522d70e08c0c6ff5349921f1777b797bddb
+DIST sphinx-autodoc-typehints-1.11.0.tar.gz 16676 BLAKE2B 8a2d8ea24ba5cc670edf1570d2c040f13aeed73ba690281846a38c9ab10b8ecfdc3c7435e3cc2099c9c2c1ec2e247ac520668edaf16630b24753ce01065cb573 SHA512 9ffdeccc58ae349fac5e94fac0495c0a2c037293bd5f49a0a5f9844881b6af08b8a3de02fccf68ec14e3301121ebfc212a3dd20c986cee2784b06f899b8b5ea4
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.11.0.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.11.0.ebuild
new file mode 100644
index 000000000..2041cfa6f
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.11.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension "
+HOMEPAGE="
+ https://github.com/agronholm/sphinx-autodoc-typehints
+ https://pypi.org/project/sphinx-autodoc-typehints
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/sphobjinv[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # skip these tests: need internet
+ sed -i -e 's:test_parse_annotation:_&:' \
+ -e 's:test_format_annotation:_&:' \
+ -e 's:test_format_annotation_both_libs:_&:' \
+ tests/test_sphinx_autodoc_typehints.py || die
+
+ distutils-r1_python_prepare_all
+}