aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/svt-vp9/svt-vp9-0.3.0.ebuild')
-rw-r--r--media-libs/svt-vp9/svt-vp9-0.3.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/svt-vp9/svt-vp9-0.3.0.ebuild b/media-libs/svt-vp9/svt-vp9-0.3.0.ebuild
new file mode 100644
index 000000000..5c474543d
--- /dev/null
+++ b/media-libs/svt-vp9/svt-vp9-0.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic cmake
+
+DESCRIPTION="Scalable Video Technology for VP9 (SVT-VP9 Encoder)"
+HOMEPAGE="https://github.com/OpenVisualCloud/SVT-VP9"
+
+if [ ${PV} = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/OpenVisualCloud/SVT-VP9.git"
+else
+ SRC_URI="https://github.com/OpenVisualCloud/SVT-VP9/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+ S="${WORKDIR}/SVT-VP9-${PV}"
+fi
+
+LICENSE="BSD-2-with-patent"
+SLOT="0/1"
+
+DEPEND="dev-lang/nasm"
+
+src_prepare() {
+ append-ldflags -Wl,-z,noexecstack
+ cmake_src_prepare
+}